12

I recently installed the proprietary Intel drivers for my Toshiba Satellite A105 s4284 running Ubuntu 14.10. Nouveau was working just fine, I was just attempting to make it so that I was able to run CS:S (no need for explanation on that.)

Long story short, I went and downloaded the Intel Graphic Drivers for Linux* from here. After downloading and installing the .deb, I ran intel-linux-graphics-installer which opened up a window that downloaded & installed the open Intel drivers. I then rebooted, and it's slow. Very slow, especially on 3D effects and when I hit Alt+Tab.

Now, I don't know if the previously installed Nouveau drivers are conflicting with these new Intel drivers (if that's the issue, what should I do about fixing it?) What I do know is that my system isn't behaving right and I want it to (obviously.) If removing the Nouveau drivers isn't the solution, how can I safely remove the just-installed Intel drivers?

Does anyone have any suggestions?

  • 1
    FWIW, the Intel drivers are not proprietary. If your laptop has a dual-graphics setup with both Intel and Nvidia, I don't think you can switch between them without proprietary Nvidia drivers. And I think from what you're saying, is that you want the Nvidea drivers, so you can get better performance with CS:S? – dobey Oct 2 '14 at 21:01
  • Yes, I realized that. My laptop only has Intel, I thought Intel was proprietary. As for why I wanted the Intel drivers, it's because I was getting errors starting CS:S, and I'd heard using intel drivers fixes that issue. However, it doesn't seem to. – RPiAwesomeness Oct 2 '14 at 21:22
14

On some computers the new versions that are installed with the intel-linux-graphics-installer have those exact same issues, I had it happen with two netbooks so it dosn't seem to be a conflict between nouveau/intel but a problem with the newer graphics installed from Intel.

  1. First you need to remove the source that Intel installed automatically when you ran the installer. To do this go to Software Center → Edit → Software Sources → Other Software and uncheck the sources that have https://download.01.org/ in the address.

  2. Next do a sudo apt-get update then we are going to follow steps from this post: https://askubuntu.com/a/405453/47291 do:

    nano /tmp/a_p
    

    And paste the following text:

    Package: *
    Pin: release a=*-backports
    Pin-Priority: 100
    
    Package: *
    Pin: release n=*
    Pin-Priority: 1001
    

    Now save with Ctrl+o and exit

  3. Now enter this command:

    sudo apt-get -o Dir::Etc::Preferences=/tmp/a_p dist-upgrade
    
  4. Reboot

  • I followed your instructions and downgraded the packages. However I also noticed that the utility installed the following packages which your instructions didn't remove: libva-tpi1 libva-egl1 libegl1-mesa-drivers vainfo i915-4.6.3-4.4.0-dkms libosmesa6 libva-wayland1 libva-glx1. What should I do with these packages? Should I purge them? – user364819 Sep 3 '16 at 22:23
  • as long as the animations, and graphics speed back up to normal - I wouldn't touch them, it may be possible that these were upgraded packages and are still around because earlier versions existed before using the utility. – Mateo Sep 3 '16 at 22:56
  • In my logs it says that they were installed rather than upgraded (it does make the distinction). And the animation is still not back to normal so shall I purge them? – user364819 Sep 4 '16 at 9:09
  • Also, I have calculated, and it seems as though the tool upgraded 34 packages, however your command downgraded 41 of them. Is that fine? – user364819 Sep 4 '16 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.