The internet is so slow as to be unusable. And I'm not being picky. Even after minutes I can't get my Google home page to load. I tried installing a package through apt-get and was getting rates between 0 and a few hundred bytes/s. That's bytes, not kilobytes! Mostly 0 however (no exaggeration, it spends large amounts of time stalled). And I would go to a speed test web site of some kind but I can't since nothing will load.

Briefly put, the laptop I am using was connected to two wireless networks while using Ubuntu 11.04 without any issues before this. It was also connected to a wired network without any issues. It dual boats Windows 7 which has never had any issues, not even with the current wireless network.

Just to be clear, on the current wi-fi network, Windows 7 encounters no issues (speedtest.net puts the network speed at 1mb/s) but my network connection in Ubuntu 11.04 is so slow as to literally be unusable.

I am unfamiliar with the router except for the fact that it boasts a Rogers logo (that's a large ISP/cable provider in Canada for those not familiar with the land of igloos and polar bears). I am far from the router and some desktop widget I use tells me the signal strength is at 58% (it seems fairly reliable and this would appear to match up with the filled bars in the network icon).

I should also mention I'm just renting a room in this house so I'm not the network administrator and while I can access the router page, the password wasn't set to 'password' so it's not much use to me.

Here are a bunch of commands I ran which don't tell me a whole lot but I thought might be more instructive to the wise around here:

lspci (just showing my network card):

05:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)

This one is self explanatory.

PING www.googele.com ( 56(84) bytes of data.
64 bytes from nnw.net ( icmp_req=1 ttl=51 time=267 ms
64 bytes from nnw.net ( icmp_req=2 ttl=51 time=190 ms
64 bytes from nnw.net ( icmp_req=3 ttl=51 time=212 ms
64 bytes from nnw.net ( icmp_req=4 ttl=51 time=207 ms
64 bytes from nnw.net ( icmp_req=5 ttl=51 time=220 ms

--- www.googele.com ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4003ms
rtt min/avg/max/mdev = 190.079/219.699/267.963/26.121 ms


eth0      Link encap:Ethernet  HWaddr 20:6a:8a:02:20:da  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:960 (960.0 B)  TX bytes:960 (960.0 B)

wlan0     Link encap:Ethernet  HWaddr 20:7c:8f:05:c6:bf  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::227c:8fff:fe05:c6bf/64 Scope:Link
          RX packets:982 errors:0 dropped:0 overruns:0 frame:0
          TX packets:658 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:497250 (497.2 KB)  TX bytes:95076 (95.0 KB)

Thank you

2 Answers 2


The answer from the blog is:

sudo iwconfig wlan0 power off

The blog then went on to describe how to automate that command. Using any editor, open /etc/pm/power.d/wireless

# Command line
sudo -e /etc/pm/power.d/wireless

# gedit
gksu gedit /etc/pm/power.d/wireless

And add in the following line


/sbin/iwconfig wlan0 power off

And the final tip is to edit /etc/nsswitch.conf. Search for the hosts line

hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4

and change it to

hosts:          files dns 

Please read this blog.... link

  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Imagine the linked site goes down for maintenance or forever - your answer would become worthless.
    – htorque
    Commented Dec 26, 2011 at 21:41
  • You have also included a link.. :D Any-way thanks for update..... Commented Dec 30, 2011 at 5:26
  • @ManishTrivedi The link in htorque's comment included the essential message; the link was present for reference. In contrast, your post has no substance besides the link. We're not against links. We just think answers should answer the question, rather than refer generically to some other answer somewhere else. Commented Sep 6, 2012 at 13:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .