0

I'm using Ubuntu 14.04 and am trying to clone a git repository via ssh. Unfortunately this does not work due to problems with openssh-client.

In the beginning I was unable to connect to the SSH Server. The following debug output was produced:

OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to test.com [ommitted] port 22.
debug1: Connection established.
debug1: identity file /home/jan/.ssh/id_rsa type 1
debug1: identity file /home/jan/.ssh/id_rsa-cert type -1
debug1: identity file /home/jan/.ssh/id_dsa type -1
debug1: identity file /home/jan/.ssh/id_dsa-cert type -1
debug1: identity file /home/jan/.ssh/id_ecdsa type -1
debug1: identity file /home/jan/.ssh/id_ecdsa-cert type -1
debug1: identity file /home/jan/.ssh/id_ed25519 type -1
debug1: identity file /home/jan/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.6.1p1 Ubuntu-2ubuntu2
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3
debug1: match: OpenSSH_5.3 pat OpenSSH_5* compat 0x0c000000
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<3072<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP

After having uncommented the Ciphers and the MACs line in /etc/ssh/ssh_config as described in https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/174168. I am able to connect via ssh.

Unfortunately I am still unable to clone the repository via git using ssh:

jan@jan-ThinkPad-T510:~$ GIT_CURL_VERBOSE=1 GIT_TRACE=1 git clone   ssh://user@host/path/to/repo
trace: built-in: git 'clone' 'ssh://user@host/path/to/repo' Cloning into 'repo'...
trace: run_command: 'ssh' 'user@host' 'git-upload-pack '\''/path/to/repo'\'''

Any idea what causes this problem?

  • ssh://user@host/path/to/repo should be user@host:/path/to/repo – George Politis Oct 2 '14 at 17:00
  • shouldn't and doesn't make a difference – Jan B Oct 2 '14 at 18:36
0

The problem occured due to different MTU settings and a probably misconfigured firewall at my internet provider (KabelBW).

I solved the problem by setting the MTU to 576 via

ifconfig wlan0 mtu 576

Note that after setting the MTU, you have to disconnect and reconnect to the network. For further Details have a look at Snailbook MTU Mismatch

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.