1

I just bought Acer Aspire V15 Nitro (VN7-591g) with Windows 8.1. I installed Ubuntu 14.04 and the touch-pad does not work! I even downgraded to 12.04, but the problem still remains. I guess that's a bug in the Linux kernel or there are no proper drivers at the moment. I hope some one will fix this soon.

FN+f7 does nothing!

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ HID 1241:1166                             id=11   [slave  pointer  (2)]
⎜   ↳                                           id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ HD WebCam                                 id=13   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]
    ↳ Acer WMI hotkeys

                      id=15   [slave  keyboard (3)]

Please help with that!

2 Answers 2

3

I had an identical problem with the Acer V17 Nitro (VN7), but upgrading the Linux kernel even to version 3.18 did not completely solve the problem, but only made the touchpad work while right/left clicks on the ClickPad part are ignored.

The enable-rightbutton.sh code did not work either and return the error that there is no property such as "Synaptics Soft Button Areas"...

Moreover - Before, when typing:

xinput

The name near device 11 was showing 'Synaptics' while now it showed as 'UNKOWN'!

After some further research I noticed that I can still get the list of properties from the 'UNKOWN' device by typing:

xinput --list-props 11

And found that it indeed no property called "Synaptics Soft Button Areas" but it did have a property called "Synaptics ClickPad" which was set to 0 (= false). I set it to '1' by typing:

xinput set-prop 11 "Synaptics ClickPad" 1

and what do you know, now the missing "Synaptics Soft Button Areas" came back, and I could see it when typing:

xinput --list-props 11

So, the Linux Kerner did not automatically activate the ClickPad features and saw it as a TouchPad. Once activated, all was fine. At this stage, the enable-rightbutton.sh script worked well, and I got a full working ClickPad as intended.

What was left to do is just to add the script to run automatically at the 'Startup Applications'

Hope that helps!

2

I had the same problem. I updated my Kernel to 3.16 and after that everything was fine. You can follow the description here http://ubuntuhandbook.org/index.php/2014/08/install-upgrade-linux-kernel-3-16/

2
  • There's a more detailed description of the kernel update procedure at askubuntu.com/a/539058/175814. Use this as reference for your answer if you like. Oct 22, 2014 at 22:35
  • Great! Kay's solution worked for me! Oct 30, 2014 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.