How can I open magnet links with firefox? I tried setting following values in about:config,

network.protocol-handler.app.magnet -> /usr/bin/deluge
network.protocol-handler.expose.magnet -> true
network.protocol-handler.external.magnet -> true

But firefox keeps on complaining about

Firefox doesn't know how to open this address, because the protocol (magnet) isn't associated with any program.

I am using repository version of firefox (5) and deluge (1.3.1 - gui+daemon mode) on ubuntu 11.04

Edit: I was told to set network.protocol-handler.expose.magnet to false and firefox would ask which application to use, but I see no box asking me something appearing.

  • @Eyal Good idea. I've flagged this question for merging with one of the dupes. This will move all answers over.
    – Seth
    Mar 13, 2013 at 0:11

7 Answers 7


as of firefox 3.6 network.protocol-handler.external.* seems to no longer work

in about:config

network.protocol-handler.expose.magnet -> false

and 'reset' all other values to do with magnet.

once you click a magnet link you will be prompted to choose an application, navigate to and select /usr/bin/deluge

You might also try

$ gconftool-2 -t string -s /desktop/gnome/url-handlers/magnet/command 'deluge "%s"'
$ gconftool-2 -t bool -s /desktop/gnome/url-handlers/magnet/needs_terminal false
$ gconftool-2 -t bool -s /desktop/gnome/url-handlers/magnet/enabled true
  • Yes, I tried this (including the reset) but it didn't ask anything. The thing is this worked with Transmission (default app), but after I uninstalled transmission I can't get it to point to deluge in any way.
    – KillianDS
    Jul 18, 2011 at 6:43
  • Strange, worked for me. I've added the steps for changing gnome's default url handling, dont think firefox takes any notice of it but its worth a try.
    – Smithamax
    Jul 18, 2011 at 8:02
  • Okay, thanks, I'll try it again as soon as I get home.
    – KillianDS
    Jul 18, 2011 at 8:04
  • 2
    the other thing to check is in firefox's preferences under applications, if there is already an entry for magnet.
    – Smithamax
    Jul 18, 2011 at 8:52
  • Well, selecting "use..." there and manually going to /usr/bin/deluge did the trick, thank you :)!
    – KillianDS
    Jul 18, 2011 at 21:53

In Firefox go to Edit/Preferences/Applications, search magnet and set Deluge

enter image description here


Instead of clicking on the magnet link in Firefox (which requires some advanced configuration to set up), right-click on the link and select "Copy Link Location". Then, move into your Deluge window, click Add Torrent (the "+" at the top-left of the window), and then click the "URL" button.

Happy torrenting, and remember to go for a 3:1 seed ratio!

  • Well, it's not really that advanced, but that can be solved with a quick google search (I would tell you if I actually remembered how, I'm kind of a noob too). Jun 23, 2012 at 22:59
  • This is more of a workaround than a solution to the problem as stated, but it's good to note it, yes :) Oct 2, 2016 at 4:30

was trying to get magnets to open with deluge in chrome rather than firefox but after trying everything else i had seen i finally managed to make magnet links open in deluge by not only changing




in /usr/share/applications/deluge.desktop but also removing


from /usr/share/applications/transmission-gtk.desktop before running

sudo update-desktop-database

hope this helps anyone with similar problems


Have you actually installed deluge? If not, open a terminal and enter this command. sudo apt-get install deluge When its done it should show up in the programs list.

  • I think that the problem is he doesn't know how to get it to link with firefox (e.g. he clicks a magnet link and then firefox wants to know what to open it with and asks him to browse to the executable). Jun 23, 2012 at 22:56

This worked for me, FF 47, Debian 9, KDE 5:

  1. In about:config find "network.protocol-handler.expose-all", change to "false";
  2. Click on some magnet link - a file browser pop-up should appear, show it full path to the executable (/usr/bin/qbittorrent for ex.);
  3. Change "network.protocol-handler.expose-all" back to "true";
  4. Download the world.
  • thanks, this is the only solution that worked for me, so weird Jul 15, 2017 at 9:37

The deluge.desktop file that's installed (in /usr/share/applications or similar) by the deluge package should already contain the


line that associates deluge with magnet links. However, in my case I found that for the system to pick up this association, I had to run:

sudo update-desktop-database

If this command is not found, the package desktop-file-utils needs to be installed first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.