4

I have had a problem with my ubuntu software-center for a while now. It refuses to start completely. So i have looked into all the web dungeons for answers with failed attempts in recovery. First I will start with the error i get when running software center on the command line. This is what i get:

2014-10-01 14:08:35,558 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2014-10-01 14:08:35,681 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/dbus/proxies.py', 410, '_introspect_error_handler')'
2014-10-01 14:08:35,681 - dbus.proxies - ERROR - Introspect error on com.ubuntu.sso:/com/ubuntu/sso/credentials: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/lib/ubuntu-sso-client/ubuntu-sso-login exited with status 1
Traceback (most recent call last):
  File "/usr/bin/software-center", line 130, in <module>
    app = SoftwareCenterAppGtk3(options, args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 338, in __init__
    self.icons)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/appmanager.py", line 66, in __init__
    self.oauth_token = helper.find_oauth_token_sync()
  File "/usr/share/software-center/softwarecenter/backend/ubuntusso.py", line 141, in find_oauth_token_sync
    sso.find_credentials()
  File "/usr/share/software-center/softwarecenter/backend/login_impl/login_sso.py", line 74, in find_credentials
    self.proxy.find_credentials(self.appname, self._get_params())
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/lib/ubuntu-sso-client/ubuntu-sso-login exited with status 1

This is are the solutions that i have tried without success:

1st:

sudo apt-get purge software-center
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install software-center
sudo dpkg-reconfigure software-center --force

2nd:

sudo apt-get install -f

3rd

sudo pip install --upgrade oauthlib

4th

gksudo software-center

Will appreciate any help in getting this problem solved. All other solutions that come will try them and if they don't work will add them to the list here.

Some suggested solutions that i have tried and not worked:

1st

sudo chmod -R +rx /usr/local/lib/python2.7/dist-packages/ 

2nd

sudo chown -R $USER:$USER /usr/local/lib/python2.7/dist-packages/

3rd

sudo apt-get install --reinstall python-ubuntu-sso-client ubuntu-sso-client ubuntu-sso-client-qt

After helpful insight, i have been directed to this link here that shows this being a bug and there is a bug report on it. So it seems we shall have to wait and see. If anyone has any hacks through this please post it here.

HACKS

1st

Use an alternative package manager and synaptic package manager is recommended.

sudo apt-get install synaptic
  • 1
    possible duplicate of Ubuntu Software Center does not open - dbus error – mchid Oct 1 '14 at 12:17
  • it looks like the exact same error from the bug mentioned in the duplicate post. I have that problem from time to time and have used the synaptic package manager when software-center does not open. To install: sudo apt-get install synaptic and to run synaptic: sudo synaptic – mchid Oct 1 '14 at 12:20
  • By the mentioned dbus error, does this mean that currently there is no fix for this? – waweru Oct 1 '14 at 13:06
  • Your errors show that the problem is most likely to do with your sso integration. Disable all your webapps in System Settings > Online Accounts. Then, run this command in a terminal to start it up: sudo software-center – mchid Oct 2 '14 at 11:03
  • 1
    You need to see why the sso program isn't starting. Try running /usr/lib/ubuntu-sso-client/ubuntu-sso-login in a terminal to see what errors it has, and why it won't start. A common reason this happens is that you've done something under sudo, which causes files to be created as root user in your home directory, causing permissions problems when running as a normal user. – dobey Jan 7 '15 at 20:49

protected by Community May 1 '16 at 6:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.