0

I'm newbie in Ubuntu and I'm having a hard time to work with jack audio. I have started to use Ardour and the problem is the Jack server apparently does not recognize my digitech rp500 pedalboard connected through USB.

When I use it in Windows with Adobe Audition it's just plug&play. In Ubuntu I have only succeeded with Audacity.

But in the Jack server (in order to use Ardour) only appears in the "Alsa" tab, but never in the "Audio" tab. I can't figure out how to connect all these components to record my guitar with Ardour. I have tried connecting RP500 out -> Midi in, in the Alsa tab and Midi out-> Ardour in, in the Audio tab, but nothing worked.

Apparently Jack server is working fine since I've been able to record something from Yoshimi and the RP500 driver is OK as well, since Audacity works fine with it.

Any help would be appreciate.

Thank you very much!!!

  • Does it require a driver in Windows? – CL. Oct 1 '14 at 10:31
  • I didn't do anything special, I just installed the management software as I did in Ubuntu... but if a driver is missing I guess audacity wouldn't work either, would it? – JuanN Oct 1 '14 at 10:57
  • What management software did you install, in Windows and in Ubuntu? – CL. Oct 1 '14 at 11:04
  • In windows X-Edit, in Ubuntu GDigi – JuanN Oct 1 '14 at 11:21
  • Okay, that is not a driver. MIDI apparently works (the ALSA tab should be labeled "MIDI"), but does it appear in the output of aplay -l or arecord -l? – CL. Oct 1 '14 at 11:49
1

Run "qjackctl" (install it eventually) , clic "settings".
Look for the "interface" selection and clic on the ">" near it: you should see your usb device in the list.
Just select it and close and restart Qjackctl : now you should see "system" with "playback" and "capture" in the audio connection window .

Delayed recording problem : the delay on the recorded sound (latency) is caused by the "sample/periods" setting (1024 on the screen capture): set it to 128 or 256. The obtained latency is displayed in the bottom right : 5 ms or less is excellent , around 10 ms is ok.
If you set latency too low , you will get clics ("xruns") when recording with Ardour.
Stop Ardour, jack and qjackctl for applying changes

Audio level problem: You must first set an acceptable level for Ardour using alsamixer in a terminal or gnome-alsamixer (install it) , select your usb sound card (F6 in alsamixer, click on the relevant tab in gnome-alsamixer), then increase "capture" faders etc...
Ardour as a built-in mixer but incoming sound level must be roughly good.

No sound from other programs : Normal, as jackd takes the sound card , disabling pulseaudio (this is automatic).So stop jackd with qjackctl when you don't use Ardour.
You can use also jack compatible programs like vlc (vlc-jack, to be installed) . This thread shows how to connect Firefox to jackd but it is not very useful in your case.

enter image description here

  • Thank you very much for your answer!!! It worked more or less! The thing now is I got some delay between my guitar and the sound output through the speakers and the gain seems to be very very low unless I use some middle software like Rakarrack. Another point is the whole sound system seems to fail whenever I start Jack: any program with sound output automatically stops working (media players, Tuxguitar...) – JuanN Oct 1 '14 at 15:30
  • I edited the answer – laugeo Oct 1 '14 at 17:37
  • Everything works fine now!!! Thank you very much for your help!! – JuanN Oct 2 '14 at 8:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.