9

I want the touchpad to get disabled while typing.

Opening the system configuration and selecting "Pointing Devices" I can change only very basic settings, namely the primary and secondary button assignment, double click speed and cursor movement speed.

So, let's google...

I have found this. Further details about reasons or possible fixes are missing.

Some work-arounnds that I have found doesn't work for me. My system doesn't seem to load synaptics driver:

If type synclient I get Couldn't find synaptics properties. No synaptics driver loaded?.

I have also installed synaptiks, but at run it says that it can't find any touchpad.

Nevertheless, the basic functions of the touchpad work.

I don't know if this is relevant: my notebook is an Acer Aspire E 15 ES1-511-C18C and the Ubuntu version is, as I have said in the title, 14.04. If I run the app "Mouse and Touchpad", I can see that the device detected is "PS/2 Elantech Touchpad".

ajh@ANTONIO-ACER:~$ syndaemon 
ajh@ANTONIO-ACER:~$ killall syndaemon
syndaemon: proceso no encontrado
ajh@ANTONIO-ACER:~$ syndaemon -i 1 -K d
ajh@ANTONIO-ACER:~$ killall syndaemon
syndaemon: proceso no encontrado
ajh@ANTONIO-ACER:~$ syndaemon -i 1 -K -d
ajh@ANTONIO-ACER:~$ killall syndaemon
syndaemon: proceso no encontrado

(Note: "Proceso no encontrado" is "process not found" in Spanish).

8

First entirely undo the current setting: Remove the tick for Disable touchpad while typing in Mouse & Touchpad settings.

Now search for and open Startup Applications from the Dash. Click Add.

Name: Syndaemon

Command: syndaemon -i 1.0 -K -R -t

Comment: Disable touchpad while typing, with a reasonable delay and only for tapping and scrolling

The -i 1.0 parameter sets the idle time of the keyboard to 1s. -K option ignores the Modifier keys. -R option uses the XRecord extension for detecting keyboard activity instead of polling the keyboard state. -t option disables tapping and scrolling but not mouse movements.

Click Add and then Close.

Reboot your computer.

Note: this is a user preference, so repeat this in every user account.

  • Good solution, but works better for me without the -R option. – lreeder Jul 12 '15 at 18:09
  • The -t seems to permanently disable tap to click and two finger scrolling permanently. – zorkerz Feb 8 '16 at 14:15
  • 2
    This has not worked for me. After a few minutes my touchpad stops responding entirely. Notably I don't have the option to Disable touchpad while typing on ubuntu 15.10 – zorkerz Feb 8 '16 at 15:09
  • @zorkerz I'm still having the same problem under Ubuntu 16.04 any luck? – Mehdi Bounya Dec 15 '17 at 19:15
3

Open a terminal window and run:

gsettings get org.gnome.settings-daemon.peripherals.touchpad disable-while-typing

It should output:

true

If it doesn't, run:

gsettings set org.gnome.settings-daemon.peripherals.touchpad disable-while-typing true

Alternatively, you can install dconf editor:

sudo apt-get install dconf-editor

Open dconf-editor and browse to "org" > "gnome" > "settings-deamon" > "peripherals" > "touchpad", and tick "disable-while-typing":

enter image description here

  • 1
    I have installed this dconf-editor, and the setting "disable while typing" is already enabled. But it doesn't work at all. I can type with the keyboard and click with the touchpad simultaneously. – user2425 Oct 2 '14 at 8:48
  • @user2425 I am really sorry to hear that, I was hoping the setting in itself would be the problem. is any of the comments helping you? – Jacob Vlijm Oct 2 '14 at 15:30
  • Not yet. My problem seems to be that the touchpad is detected as a mouse. I have entered the BIOS Setup and there's no option to change this behaviour. – user2425 Oct 3 '14 at 10:36
  • 4
    I get - "No such schema 'org.gnome.settings-daemon.peripherals.touchpad'" – Alexander Mills Dec 2 '16 at 21:21
  • 1
    @AlexanderMills here are some options. I didn't try them: askubuntu.com/questions/762189/… – Jacob Vlijm Dec 2 '16 at 21:42

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.