4

Everything was working but suddenly stopped. I just didn't upgrade my Ubuntu 14.04 for two months. Now when I want to upgrade I get some errors.

First I run sudo apt-get update:

E: GPG error: http://dl.google.com stable InRelease: Clearsigned file isn't valid, got 'NODATA' (does the network require authentication?)

I search for a solution and found this, but now when I try to import the key, I get another error. While importing the key:

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

I get this error:

gpg: no valid OpenPGP data found.

How to solve this problem?

  • What's your GnuPG version? check with gpg --version – radriaanse Oct 1 '14 at 8:47
  • @remyseroos gpg (GnuPG) 1.4.16 – Omid Oct 1 '14 at 8:49
  • 1
    Can you see the key if you just go to the url from your browser? – radriaanse Oct 1 '14 at 8:59
  • @remyseroos Oh, No! I can't see it. Thank you man. Solved! – Omid Oct 1 '14 at 9:05
  • np, Can you please write out your solution/finding as an answer, and mark it solved? – radriaanse Oct 1 '14 at 9:26
4

The problem was due to the restriction in my country. As @remyseroos suggested me, I tried to open the URL (https://dl-ssl.google.com/linux/linux_signing_key.pub) in my browser and I found out it's not loading properly.

So I just used a proxy and problem solved!

| improve this answer | |
  • My problem too. Which proxy you used? – Afshar Mohebi Jan 1 '15 at 4:38
  • @afsharm Any VPN service should work. – Omid Jul 12 '15 at 11:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.