1

I just bought a new Acer Aspire V 15 Nitro computer with a pre-installed Windows 8. I installed Ubuntu so I can run dual-boot. Everything works fine now except my touch-pad that isn't working in Ubuntu but works fine when i boot into Windows. And when i'm in Ubuntu my USB mouse works fine aswell.

 cat /proc/bus/input/devices

This command does not show any SynPS/2 or anything.

When i run

    xinput --list

Under the Virtual core pointer there is only one

    Virtual core XTEST pointer
    Logitec USB-PS/2 Optical Mouse

and then there is a empty slot where I think my touch-pad should be.

In my system settings I can see the touch-pad and turn it on/off but nothing happens. I also installed Touch-pad indicator but nothing happens aswell.

EDIT

When I run

    cat /var/log/Xorg.0.log | grep -i synaptics


    [     4.362] (**)    : Applying InputClass "enable synaptics SHMConfig"
    [     4.362] (II) LoadModule: "synaptics"
    [     4.362] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
    [     4.362] (II) Module synaptics: vendor="X.Org Foundation"
    [     4.362] (II) Using input driver 'synaptics' for '   '
    [     4.388] (--) synaptics:    : x-axis range 0 - 1236 (res 12)
    [     4.388] (--) synaptics:    : y-axis range 0 - 898 (res 12)
    [     4.388] (II) synaptics:    : device does not report pressure, will use                 touch data.
    [     4.388] (II) synaptics:    : device does not report finger width.
    [     4.388] (--) synaptics:    : buttons: left double triple
    [     4.388] (--) synaptics:    : Vendor 0x6cb Product 0x2970        
    [     4.388] (--) synaptics:    : invalid pressure range.  defaulting to 0 -         255
    [     4.388] (--) synaptics:    : invalid finger width range.  defaulting to 0         - 15
    [     4.388] (--) synaptics:    : touchpad found
    [     4.404] (**) synaptics:    : (accel) MinSpeed is now constant deceleration 2.5
    [     4.404] (**) synaptics:    : (accel) MaxSpeed is now 1.75
    [     4.404] (**) synaptics:    : (accel) AccelFactor is now 0.131
    [     4.404] (--) synaptics:    : touchpad found

After running

     grep -i touchpad /var/log/Xorg.0.log

the output is

      [     4.362] (**)    : Applying InputClass "evdev touchpad catchall"
      [     4.362] (**)    : Applying InputClass "touchpad catchall"
      [     4.388] (--) synaptics:    : touchpad found
      [     4.404] (II) XINPUT: Adding extended input device "   " (type: TOUCHPAD, id 12)
      [     4.404] (--) synaptics:    : touchpad found
      [     4.404] (**)    : Ignoring device from InputClass "touchpad ignore duplicates"

but when i run

      xinput -list

there is nothing with id 12

      ⎡ Virtual core pointer                        id=2    [master pointer  (3)]
      ⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
      ⎜   ↳ Logitech USB-PS/2 Optical Mouse             id=11   [slave  pointer  (2)]
      ⎜   ↳                                             id=12   [slave  pointer  (2)]

I'm new to Ubuntu so be kind, but I would love some help. And sorry for my English.

  • Check dmesg | grep psmouse. Is 'psmouse' driver actually running? This can be delayed (for reasons unknown) for up to 8-10 minutes. Something to do with power-saving and Windows. Are you also running Windows on the PC, or have you recently? – david6 Dec 29 '14 at 21:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.