2

Sorry about that last post.

Info: I am running Ubuntu Desktop 14.04 in VM workstation.

Question: I want to disable all and only the input sound devices and keep the output devices. I cannot find an option under sound setting GUI to do this.

Reason: I don't have a microphone plugged into my computer. If Ubuntu tries to access input sound device when I don't have an input device on my host (Windows 7), then VMware workstation would say "Device ID out of range, sound adapter will be disconnected." This will disconnect both the input and output device (because it is in one VMWare virtualized sound adapter). I want to get output, and don't want the sound adapter to disconnect.

Things I have tried: Muting all the input devices doesn't work.

Thanks.

6
  • committed a sin, lol. What are you trying to do exactly? Why are you trying to access an input device, what are you trying to access here ? – Panther Oct 1 '14 at 3:54
  • I asked a question about Mint on here. But anyway, Ubuntu would behavior the same. It is automatic for the System to try to access input sound device, which causes VMware to disconnect my sound adapter. I know if I can disable the input device, then Ubuntu won't try to access it. I just don't know how to, there is no such option in sound setting GUI. – Yang Oct 1 '14 at 4:10
  • Mint is not ubuntu and it is wrong to assume Ubuntu would act the same. Hard to know if this is a problem with mint or vmare – Panther Oct 1 '14 at 4:12
  • Not assuming, I just tested it in Ubuntu. Mint was the last question (which I referred to as a sin, otherwise it is unrelated). This is the end of the Mint discussion. We are talking about Ubuntu! (Please don't move my question again D:< ) – Yang Oct 1 '14 at 4:15
  • This appears to be an issue of the host (Windows) audio driver, or the VMWare virtual audio driver, rather than related to Ubuntu. – Takkat Oct 1 '14 at 6:06
3

I found my own answer.

Install pavucontrol (PulseAudio Volume Control) package through Synaptic or apt-get. Open Terminal and type "pavucontrol" to open the GUI. Under Configuration allows you to change profiles, which was in older version of Ubuntu default sound preference GUI but disappeared. Change profile to Analog Stereo Output instead of Analog Stereo Duplex. Ubuntu will no longer use any sound input devices.

https://help.ubuntu.com/community/SoundTroubleshootingProcedure (Step 6)

0

Though the comments above were very useful, I still feel I'm guessing exactly what you are trying to do, and I'm even less clear about why.

Providing that your quest is to DISABLE the sound card entirely, I would recommend you install the Synaptic Package Manager and use its search facility to find the INSTALLED drivers for your sound card and simply delete them. I would think that would disable more than the input, but you haven't provided strict parameters for answers.

If all you really want to do is MUTE the input aspect of your OS, that's a setting... or at least it used to be. As it happens I'm seated at a sad old laptop running Ubuntu 10.04 (no longer supported), and it's Sound Preferences screen looks suspiciously similar to (my recollections of) those of more recent releases. So if all you want to do is mute the input, please do it that easy way.

Just to cover all my bases, I checked if Synaptic had an app specifically designed to mute audio inputs. I could not find such an app, but that doesn't mean there's not a BASH command you can enter to simply mute the inputs.

1
  • I apologize for the vagueness of my question. I have revised it. I hope it clears up what I am trying to accomplish. – Yang Oct 1 '14 at 4:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.