0

Any time i launch a source game on steam i get the message

Could not find required OpenGL entry pint 'glGetError'! Either your video card is unsupported, or your OpenGL driver needs to be updated

UPDATE: I updated my intel graphics drivers and now i'm getting a different error

Could not find required OpenGL entry point 'glColorMaskIndexedEXT'! Either your video card is unsupported, or your OpenGL driver needs to be updated.

  • Welcome to AU! What kind of graphics adapter do you have? Its driver probably doesn't support the OpenGL version or extension required for the Source game engine. Can you include the output of glxinfo in your question please? – David Foerster Oct 1 '14 at 0:46
  • here. pastebin.com/b5VMmYpF – Nrgyzerbenny Oct 1 '14 at 21:12
0

glColorMaskIndexedEXT is part of the OpenGL extension EXT_draw_buffers2, which is unsupported by your graphics adapter (at least with the current driver) according to the output of glxinfo you provided.

You are very likely unable to launch Source engine based games under Linux with your current hardware.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.