1

enter image description hereIs there a simple way to edit the right click menu in Gnome?

I am running 14.04 Ubuntu Gnome, and for some reason the right click menu "whites out" my selection instead of highlighting it.

I was unable to take a screenshot of the menu up.

EDIT: Screenshot up

3
  • Are you saying, that the foreground and background colours of highlighted context menu entries make the entry text illegible? Sep 30, 2014 at 16:43
  • Yes, that's exactly what I'm saying. When I mouse-over my selection it becomes completely blanked out, instead of highlighted.
    – Wifi
    Sep 30, 2014 at 16:57
  • By the way you can take screen shots of context menus with gnome-screenshot -i and setting a delay in the menu before capturing the screen. It'll save the screen shot to your pictures folder. Sep 30, 2014 at 17:15

1 Answer 1

1

It looks like the colour scheme of your desktop environment is “off”.

(Re-)setting the GTK colour scheme

  • One possible cause is that gnome-settings-manager misbehaves or crashed. That can often be fixed by logging out of your account and logging in again.

  • Another possibility is that the colour settings themselves are somehow corrupted and you need to reset them through the system settings manager display options. Maybe try other colour schemes for comparison. You may need to log out and back in for it to take effect.

  • Similar to the previous solution, you can try select other colour schemes with gnome-tweak-tool, if that's still around in 14.04.

Fixing a broken GTK theme

The default theme for the Gnome Shell in Ubuntu 14.04 is Adwaita. You can reinstall ist with:

sudo apt-get install --reinstall gnome-themes-standard\*

Reload the current theme with Alt+F2, enter r and press ENTER.

6
  • logging out and back in has not fixed anything. Cannot find a color settings to test that. added screenshot to original post
    – Wifi
    Sep 30, 2014 at 17:33
  • Unfortunately I don't have a 14.04 setup to poke around myself. Maybe the third suggestion in my recent edit helps. Sep 30, 2014 at 17:37
  • added screenshot, cursor is over "Save As" and it's clearly missing. Will try tweak. EDIT Tweak worked when changing GTK to High Contrast, but personally I think it's an ugly look. Anything I can do other than leaving it on High Contrast?
    – Wifi
    Sep 30, 2014 at 17:41
  • At least now we know that I identified the problem cause correctly. I'll update my answer. Sep 30, 2014 at 17:57
  • broken GTK theme is Adwaita. So I should sudo apt-get install --reinstall adwaita?
    – Wifi
    Sep 30, 2014 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.