My ~/.fluxbox/startup file

# fluxbox startup-script:
# Lines starting with a '#' are ignored.

# Change your keymap:
#xmodmap "/home/rapture/.Xmodmap"

# Applications you want to run with fluxbox.
# unclutter -idle 2 &
# wmnd &
# wmsmixer -w &
# idesk &
# Debian-local change:
#   - fbautostart has been added with a quick hack to check to see if it
#     exists. If it does, we'll start it up by default.
#which fbautostart > /dev/null
#if [ $? -eq 0 ]; then
#    fbautostart

nitrogen --restore &

# And last but not least we start fluxbox.
# Because it is the last app you have to run it with ''exec'' before it.

exec fluxbox
# or if you want to keep a log:
# exec fluxbox -log "/home/rapture/.fluxbox/log"

Everytime I restart fluxbox though, the background changes to what was either set by default, or to what fbsetbg had set it as. I have two monitors so I really want to use nitrogen to set two different wallpappers.

Here is my ~/.fluxbox/init

session.screen0.titlebar.left:  Stick 
session.screen0.titlebar.right: Minimize Maximize Close 
session.screen0.tabs.usePixmap: true
session.screen0.tabs.maxOver:   false
session.screen0.tabs.intitlebar:    true
session.screen0.iconbar.alignment:  Relative
session.screen0.iconbar.mode:   {static groups} (workspace)
session.screen0.iconbar.iconTextPadding:    10
session.screen0.iconbar.iconWidth:  128
session.screen0.iconbar.usePixmap:  true
session.screen0.toolbar.height: 0
session.screen0.toolbar.alpha:  255
session.screen0.toolbar.widthPercent:   100
session.screen0.toolbar.tools:  prevworkspace, workspacename, nextworkspace, clock, prevwindow, nextwindow, iconbar, systemtray
session.screen0.toolbar.maxOver:    false
session.screen0.toolbar.visible:    true
session.screen0.toolbar.onhead: 1
session.screen0.toolbar.layer:  Dock
session.screen0.toolbar.autoHide:   false
session.screen0.toolbar.placement:  RightTop
session.screen0.slit.acceptKdeDockapps: true
session.screen0.slit.alpha: 255
session.screen0.slit.maxOver:   false
session.screen0.slit.onhead:    0
session.screen0.slit.placement: RightBottom
session.screen0.slit.layer: Dock
session.screen0.slit.autoHide:  false
session.screen0.tab.placement:  TopLeft
session.screen0.tab.width:  64
session.screen0.menu.alpha: 255
session.screen0.window.focus.alpha: 255
session.screen0.window.unfocus.alpha:   255
session.screen0.clientMenu.usePixmap:   true
session.screen0.showwindowposition: false
session.screen0.workspaces: 4
session.screen0.maxDisableResize:   false
session.screen0.allowRemoteActions: false
session.screen0.tooltipDelay:   500
session.screen0.autoRaise:  true
session.screen0.strftimeFormat: %d %b, %a %02k:%M:%S
session.screen0.menuDelay:  200
session.screen0.fullMaximization:   false
session.screen0.focusModel: ClickFocus
session.screen0.tabFocusModel:  ClickToTabFocus
session.screen0.clickRaises:    true
session.screen0.focusSameHead:  false
session.screen0.focusNewWindows:    true
session.screen0.maxIgnoreIncrement: true
session.screen0.maxDisableMove: false
session.screen0.windowMenu: /home/rapture/.fluxbox/windowmenu
session.screen0.edgeSnapThreshold:  10
session.screen0.opaqueMove: true
session.screen0.defaultDeco:    NORMAL
session.screen0.workspaceNames:  1, 2, 3, Let's Jam,
session.screen0.noFocusWhileTypingDelay:    0
session.screen0.rowPlacementDirection:  LeftToRight
session.screen0.colPlacementDirection:  TopToBottom
session.screen0.windowPlacement:    RowMinOverlapPlacement
session.screen0.workspacewarping:   true
session.styleFile:  /usr/share/fluxbox/styles/Makro
session.colorsPerChannel:   4
session.autoRaiseDelay: 250
session.forcePseudoTransparency:    false
session.ignoreBorder:   false
session.appsFile:   /home/rapture/.fluxbox/apps
session.configVersion:  13
session.cacheLife:  5
session.slitlistFile:   /home/rapture/.fluxbox/slitlist
session.cacheMax:   200
session.tabsAttachArea: Window
session.tabPadding: 0
session.keyFile:    ~/.fluxbox/keys
session.menuFile:   ~/.fluxbox/menu
session.styleOverlay:   /home/rapture/.fluxbox/overlay
session.doubleClickInterval:    250


rapture@rapture:~/.fluxbox$ cat overlay 
! The following line will prevent styles from setting the background.
! background: none


rapture@rapture:~/.fluxbox$ cat /usr/share/fluxbox/styles/Makro
# "Makro"
# A Fluxbox theme by: skypher of perplexity
# 2001

toolbar:                             Gradient Vertical Sunken
toolbar.color:                       rgb:CC/CC/AA

toolbar.button:                      Flat Solid
toolbar.button.color:                rgb:AB/90/40
toolbar.button.picColor:             rgb:50/30/10

toolbar.button.pressed:              Sunken Flat
toolbar.button.pressed.color:        rgb:90/70/20

toolbar.clock:                       Flat
toolbar.clock.color:                 rgb:AB/90/40
toolbar.clock.textColor:             rgb:40/20/05

toolbar.label:                       Flat
toolbar.label.color:                 rgb:AB/90/40
toolbar.label.textColor:             rgb:40/20/05

toolbar.windowLabel:                 Flat
toolbar.windowLabel.color:           rgb:AB/90/40
toolbar.windowLabel.textColor:       rgb:40/20/05

toolbar.justify:                     Left

menu.title:                          Raised Flat
menu.title.color:                    rgb:AB/90/40
menu.title.textColor:                rgb:40/20/05
menu.title.justify:                  Left

menu.frame:                          Gradient PipeCross
menu.frame.color:                    rgb:CC/CC/AA
menu.frame.colorTo:                  rgb:AB/AA/90
menu.frame.textColor:                rgb:10/10/01
menu.frame.justify:                  Right

menu.hilite:                         Flat
menu.hilite.color:                   rgb:DF/CF/BF
menu.hilite.textColor:               rgb:00/00/00

menu.bullet:                         Square
menu.bullet.position:                Right

window.title.focus:                  Gradient Vertical Sunken
window.title.focus.color:            rgb:CC/CC/AA

window.title.unfocus:                Gradient Vertical Sunken
window.title.unfocus.color:          rgb:AC/AC/90

window.label.focus:                  Solid Flat
window.label.focus.color:            rgb:AB/90/40
window.label.focus.textColor:        rgb:40/20/05

window.label.unfocus:                Flat Solid
window.label.unfocus.color:          rgb:AA/80/30
window.label.unfocus.textColor:      rgb:45/25/10

window.button.focus:                 Flat Solid
window.button.focus.color:           rgb:AC/99/50
window.button.focus.picColor:        rgb:40/20/05

window.button.unfocus:               Flat Solid
window.button.unfocus.color:         rgb:AA/80/30
window.button.unfocus.picColor:      rgb:45/25/10

window.button.pressed:               Sunken Solid
window.button.pressed.color:         rgb:90/70/20

window.frame.focus:                  Flat
window.frame.focus.color:            rgb:00/00/00
window.frame.unfocus:                Flat
window.frame.unfocus.color:          rgb:10/10/10

window.handle.focus:                 Sunken Solid
window.handle.focus.color:           rgb:AC/99/50
window.handle.unfocus:               Flat Solid
window.handle.unfocus.color:         rgb:AA/80/30

window.grip.focus:                   Sunken Gradient Diagonal Interlaced
window.grip.focus.color:             rgb:AC/99/50
window.grip.focus.colorTo:           rgb:AA/80/30
window.grip.unfocus:                 Raised Gradient Diagonal
window.grip.unfocus.color:           rgb:AA/80/30
window.grip.unfocus.colorTo:         rgb:AC/99/50

! ----------- tab - explicit for fluxbox, the best wm out there[tm] (;
window.tab.justify:                  Center
window.tab.label.unfocus:            Flat Solid
window.tab.label.unfocus.color:      rgb:AA/80/30
window.tab.label.unfocus.textColor:  rgb:45/25/10
window.tab.label.focus:              Solid Flat
window.tab.label.focus.color:        rgb:AB/90/40
window.tab.label.focus.textColor:    rgb:40/20/05
window.tab.borderWidth:              1
window.tab.borderColor:              rgb:10/10/10
! ----------- (fluxbox.sourceforge.net)
window.tab.font:                     -*-helvetica-medium-r-*-*-11-*-*-*-*-*-iso8859-*

window.justify:                      Left

toolbar.font:                        -*-helvetica-medium-r-*-*-11-*-*-*-*-*-iso8859-*
window.font:                         -*-helvetica-bold-r-*-*-11-*-*-*-*-*-iso8859-*
menu.title.font:                     -*-helvetica-bold-r-*-*-11-*-*-*-*-*-iso8859-*
menu.frame.font:                     -*-helvetica-medium-r-*-*-10-*-*-*-*-*-iso8859-*

borderColor:                         rgb:10/10/10

bevelWidth:                          2
borderWidth:                         1
handleWidth:                         3

background: flat

1 Answer 1


Use ~/.fluxbox/startup


/usr/bin/nitrogen --restore &
/usr/bin/xscreensaver &
/usr/bin/start-pulseaudio-x11 &
/usr/bin/xcompmgr -f -c -n -C -F &

# Network manager
nm-applet >/dev/null 2>/dev/null &

wicd-client -n

exec fluxbox

See: http://blog.bodhizazen.com/linux/a-5-minute-guide-to-fluxbox/

From the comments, the fluxbox theme was setting a background.

To debug this sort of problem,

First check ~/.fluxbox/init and make sure there is not a command to set the BG, for example

session.screen0.rootCommand: fbsetbg /path/to/image

Second, check your theme and comment out or delete and lines with "background" in them, for example,

background: foo
background.color: bar
background.colorTo: bang
  • My very first line says I am.... This doesn't work, it reverts to fbsetbg's wallpaper choice.
    – Fetts Vett
    Oct 1, 2014 at 14:27
  • Okay, I put it in my post.
    – Fetts Vett
    Oct 1, 2014 at 14:38
  • If that does not work, we need to look at the theme you are using.
    – Panther
    Oct 1, 2014 at 14:41
  • Removing those did nothing. I'm using the Makro style, I'll post the file in my OP.
    – Fetts Vett
    Oct 1, 2014 at 14:43
  • Comment out the last line in your theme "background: flat"
    – Panther
    Oct 1, 2014 at 14:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .