5

I am running ubuntu 14 on a mac machine. recently I notice compiz was too slow, so I changed from default generic driver to propietary. after that, I got a blank screen.

I am able to enter recovery mode, and even launch the dialog to configure graphics, but it is unusable (it did not respond to keyboard nor mouse, so no way to select any option there).

I had tried many suggestions in the forum, (reinstall compiz, unity-desktop,purge nvidia drivers, reconfigure xserver-org..) but most of them seems to be for older versions of ubuntu (by example, I don't have a xorg.conf file) so I wonder if there are fresh instructions specific for ubuntu 14.

  • What does sudo apt-get install xserver-xorg-video-nouveau && reboot do? – eyoung100 Sep 30 '14 at 13:35
  • it was already present. I uninstalled, purged and reinstalled. after reboot it was the same: dark purple screen and after a seconds, pure-black screen. – cesarpachon Sep 30 '14 at 13:59
  • 1
    Press Ctrl + Alt + F2, then login, then can you post the output of sudo lspci | grep -i vga to verify that this is or is not an Optimus based laptop. Let's verify Ovi's hunch before you blindly do it. – eyoung100 Sep 30 '14 at 14:10
  • output of lspci grep -i vga: Advanced MicroDevices, Inc. [AMD/ATI] whistler[radeon HD 6730M/6770M/7690M XT]. it is a desktop machine. – cesarpachon Sep 30 '14 at 17:07
  • Is that the only VGA output? – eyoung100 Sep 30 '14 at 17:24
1

Next time you boot into Ubuntu, switch to a new TTY using ctrl+alt+F2. Log in with your username and password, then attempt to start the X server.

$ sudo startx

If it doesn't work then run this and then reboot:

$ sudo cp /etc/X11/xorg.conf.orig /etc/X11/xorg.conf

If you get an error then run

$ sudo ls -l /etc/X11/xorg.*

and copy the old xorg config file as xorg.conf

If this doesn't fix it then reply with the output you receive to the commands above. And also to:

$ sudo dpkg --list 'linux-image*'

and:

$ glxinfo -i | grep render

If you don't have dedicated graphics then:

$ sudo apt-get install xserver-xorg-video-intel

Then enter

$ sudo vi /etc/X11/xorg.conf

This command will create the file and open it for you. Insert the text below exactly as it appears and click save.

Section "Device" Identifier "Card0" Driver "intel" Option "AccelMethod" "sna" EndSection

If you have AMD graphics then follow this tutorial: http://wiki.cchtml.com/index.php/Ubuntu_Trusty_Installation_Guide#Removing_Catalyst.2Ffglrx

If you have nvidia then: http://www.linux.com/community/blogs/133-general-linux/774158-install-uninstall-nvidia-driver-33179-on-ubuntu-linuxmint

  • output of the above commands (yet need to try the amd tutorial): 1. sudo startx fails (weird pixels in a corner, then black screen) 2. etc/xorg.conf.orig did not exist. there is one xorg.conf.failsafe. 3. output of dpkg-list 'linux-image-*': (just copied the two lines with high version numbers:) image-3.13.0-36-generic linux image for 3.13.0 64 bit x86 SMP linux-image-extra-3.13.0-36-generic 4. output of glxinfo -i | grep render "unable to open display" – cesarpachon Sep 30 '14 at 14:48
  • followed the AMD tutorial: purged fglrx (there not exist packages..) xserver-xorg, reinstaled mesa glx, dri, and xserver-xorg-core, removed /etc/ati files. not worked. yet in black screen. – cesarpachon Sep 30 '14 at 17:18
  • "unable to open display" - I think I see the problem. Try this first: $ sudo apt-get update && sudo apt-get upgrade Then this and reply with the outputs in line: $ glxinfo | grep render $ lspci | grep VGA $ inxi -Gx $ sudo apt-get autoclean && sudo apt-get clean $ sudo apt-get autoremove && sudo apt-get -f install $ sudo dpkg --configure -a $ sudo apt-get install build-essential libssl-dev linux-headers-$(uname -r) $ sudo apt-get install linux-headers-generic – Ovi Sep 30 '14 at 17:47
  • done, the ouput of glxinfo is "unable to open display" and the most relevant info from inxi -Gx is "xorg 1.15.1, drivers=fdev,ati,radeon,intel (unloaded:fglrx,vesa)", output is the same before and after running all the commands – cesarpachon Sep 30 '14 at 18:33
  • Wow this a tough one.. Try to upgrade to a new kernel and then install the opensource drivers (not fglrx!) Get your precompiled kernel from here: kernel.ubuntu.com/~kernel-ppa/mainline/v3.16.3-utopic Tutorial for 3.14 here: yourownlinux.com/2014/04/… (just replace 3.14 with 3.16.3 links). – Ovi Sep 30 '14 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.