3

I have installed Ubuntu 14.04 in my machine(with Gigabyte motherboard), having an Acer 19" Monitor. Unfortunately its resolution not working properly. See the image.

enter image description here

This is my xrandr -q output.

enter image description here

But when I take system settings for adjusting display it shows unknown display and only two resolutions available on the drop down as given in the picture.

enter image description here

Please let me know if you need any input from my side.

Thanks in advance.

Please help me to correct the display resolution as I am a beginner to Linux and Ubuntu. This is my last 30 lines of /var/log/Xorg.0.log

enter image description here

The result of running sudo lspci | grep VGA is as follow.

00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09)
  • please give us the output of sudo lspci | grep VGA – hermest Sep 30 '14 at 4:19
  • I think it's a problem with your graphics driver, not monitor. What's your video card model? – user300458 Sep 30 '14 at 4:34
  • I don't have any graphics card installed on my system. Is there anything else you required from my side ? like any terminal command output ? – Uvais Ibrahim Sep 30 '14 at 4:49
  • What kernel version are you using? this comment makes me ask – Grizly Sep 30 '14 at 7:23
  • This is my kernal version - 3.13.0-30-generic – Uvais Ibrahim Sep 30 '14 at 8:16
2

I found this on the Arch Distro BBS maybe it can help: Intel HD Graphics 4600 driver works as Intel Xeon E3-1200

You might try installing the Intel-microcode package as well. You are most likely utilizing the Intel Processor's GPU, without knowing what model Mother Board you have.

| improve this answer | |
  • sudo apt-get install intel-microcode && sudo reboot helped me. – norbitwise Jun 24 '15 at 22:40
1

This might help someone.

Try a better VGA cable.

A poor quality VGA cable often causes this kind of problem. I've recently stumbled upon this strange problem and couldn't able to find a reasonable cause for this issue in Ubuntu (In 16.04.2 for me).

Cable type which worked for me : HOTRON E246588 AWM style 20276 VW-1 80°C 30V

| improve this answer | |
  • Thank you for this response. I ran into this problem. I was in the settings for 20 minutes and entered a few things in the command line. I began to think I needed a new monitor. Then I read this and found the connection to the VGA extension cable was just barely hanging on. Plugged it in properly and "bingo!" problem solved. Thank You! – OnePuttMike Jan 26 '19 at 7:53
  • 1
    @OnePuttMike I am glad it helped you. – Vikas Swami Jan 28 '19 at 16:53
0

Have you tried updating and upgrading your system sudo apt-get update && sudo apt-get upgrade?

Also try going to Software and Updates -> Additional Drivers and changing the display driver.

| improve this answer | |
  • Yes. I have already ran sudo apt-get update && sudo apt-get upgrade. But didn't help. Also there is no any software updates for this time. – Uvais Ibrahim Sep 30 '14 at 4:11
  • What dies Additional Drivers show? – user271219 Sep 30 '14 at 4:12
  • It says No additional drivers available. – Uvais Ibrahim Sep 30 '14 at 6:37
  • Does your login screen look the same way? – user271219 Sep 30 '14 at 14:17
  • 1
    Did you chose the option to install updates upon installation? – user271219 Oct 1 '14 at 13:44
0

just going to Software and Updates then additional drivers and change the driver by chose the most recent and stable one.

| improve this answer | |
  • On Software and Updates, in additional drivers tab, it says No additional drivers available. – Uvais Ibrahim Sep 30 '14 at 6:39
0

Try this solution.

Use sudo apt-get install nvidia-331 nvidia-settings nvidia-prime and then reboot. You can use application named nvidia x server to configure the display.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.