1

I'm loving Lubuntu so far, but I have been noticing certain problem with some applications, mainly VirtualBox.

Basically, even though my system is set in English (US) with regional settings in Spanish (AR), when I open VirtualBox it displays all the UI in Greek characters. Not in Greek, though -- it just displays the English text but using Greek characters. I have tried switching VirtualBox's language to Spanish and relaunching the program, and the same happens -- it displays the Spanish text but using Greek.

Here you can see what I mean:

VirtualBox screenshot showing English words in Greek alphabet

It also happened with other applications downloaded from the Lubuntu Software Center, such as Wine Launcher Creator. I guess it's an encoding problem? I tried googling it but all the answers I find deal with language settings, which clearly isn't the problem here, since the program is in fact displayed in the language I want -- it's the way the characters are displayed that isn't right.

  • Sounds like a font dedicated for cyrillic letters is being used, so maybe you should look for font settings for the applications in question. – Gunnar Hjalmarsson Sep 30 '14 at 4:07
  • @Gunnar Hjalmarsson Could you be a bit more specific? I tried looking at VirtualBox's settings but I really couldn't find anything that could point to the problem. Plus this also happens in other applications, so it seems to me like it's OS-related. Is there a way in Lubuntu to configure certain applications to display their UI with a specific font? – 王子露 Sep 30 '14 at 4:21
  • Do you have qt3, qt4 or both installed? – Jan Sep 30 '14 at 9:58
  • I'm afraid I can't be more specific, because I use neither Lubuntu nor VirtualBox myself. It was just an attempt to help diagnose the problem. – Gunnar Hjalmarsson Sep 30 '14 at 10:33
  • @Jan I think I don't? Is this what originated the problem? – 王子露 Sep 30 '14 at 17:43
1

Ok so, I tested installing VirtualBox on my main machine with Linux Mint 17 Qiana, and turns out the same happened, so I tried to look more in depth regarding what Gunnar Hjalmarsson said regarding "fonts for displaying cyrilic characters being used" and it turns out they were on the right path.

For some reason both in Lubuntu's and Mint's windows options I had Standard Symbols L as the default font for any text displayed system-wide, and that was causing the problem. I changed it to Sans which looks exactly the same but doesn't produce the same weird display of letters, and now the text is readable again.

  • You're welcome. I'm glad that my guess proved to be helpful. – Gunnar Hjalmarsson Oct 18 '14 at 7:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.