1

This question already has an answer here:

My Lenovo Ideapad G50-70 will automatically disconnect from the Internet at random moments on 14.04. The network will first just stop working without any warning, and after a while, it will disconnect by itself. The strange thing is, I can't manage to get the computer back online without restarting the whole computer; it will not be able to connect to the network at all. Simply turning wireless/networking off and back on doesn't help at all. I've tried following old instructions to update drivers (as shown here: http://ubuntuforums.org/showthread.php?t=2080326 ), but it didn't help.

lspci -nnk | grep -iA2 net:

~$ lspci -nnk | grep -iA2 net
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)
Subsystem: Lenovo Device [17aa:380a]
Kernel driver in use: r8168
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
Subsystem: Lenovo Device [17aa:b736]
Kernel driver in use: rtl8723be

It would be awesome if somebody could help me out! I really don't want to use Windows 8 instead. :/

marked as duplicate by Pilot6, Eric Carvalho, user364819, 2707974, v2r Sep 22 '15 at 11:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Is it happening for both wired and wireless connections? Also post your syslog regarding this issue. – heemayl Sep 29 '14 at 20:29
  • I've only used the computer with wireless connections, I'll try to check once i lose my Internet connection again. :) Update: I lost my connection while writing this, and plugged up with a wired connection. It works for now, but I have no idea if it will last. Sometimes I can go through hours before it stops working, and I have to lie on the floor to use a wired connection, so it might be a bit difficult to test. How do I see the syslog? – Stein Arne Brekke Sep 29 '14 at 20:40
  • In fact you can do this right now. Find your wireless interface by ifconfig command. Lets say your wireless interface is wlan0 then execute cat /var/log/syslog | grep -i "wlan0". This will show you all the logs regarding your wireless interface on timely basis. Paste the output in here and give us the link. – heemayl Sep 29 '14 at 20:50
  • paste.ubuntu.com/8461360 Here you go! It just asked me to enter the password for the network again, even though I'm online on a wired connection. – Stein Arne Brekke Sep 29 '14 at 20:57
  • Sep 29 22:49:32 brekkeslenovo wpa_supplicant[1142]: wlan0: CTRL-EVENT-DISCONNECTED bssid=10:bf:48:91:aa:34 reason=4 locally_generated=1. As you can see something is definitely wrong. Give the command sudo sh -c 'modprobe -r iwlwifi && modprobe iwlwifi 11n_disable=1' and check after that. This will disable the 802.11n capability of the adapter. I found this solution here and the problem described is very much similar to your one. – heemayl Sep 29 '14 at 21:24
0

After digging more i found that it's a known bug in Ubuntu for the Realtek RTL8723BE adapter. See this bug report.
Also check out this closed question on same issue.

  • Ah, okay. Thanks a lot for your efforts! It looks like a patch is right around the corner. :) I tried updating to 14.10, that didn't help just yet, at least. – Stein Arne Brekke Sep 30 '14 at 6:51
  • 14.10 has not been released yet, but remember 14.10 will not be a LTS release so you will get support for only 9 months whereas 14.04 is a LTS release that will be supported till april, 2019. This will give you a better idea. – heemayl Sep 30 '14 at 9:39
0

I found this solution, and worked perfectly on a Lenovo g40-30 so i guess it should work in other lenovo pc...

quote:

for one time test:

sudo rmmod ideapad_laptop

for working after reboot:

echo "blacklist ideapad_laptop" | sudo tee -a /etc/modprobe.d/blacklist-ideapad.conf

found it in: Wifi Not Working On Ubuntu 14.04 Lenovo G 50-30

prior to that I re-installed the module, updated the kernel to 3.16, and none of that worked.

  • I tried this; it got better, but not perfect; I would still have to restart every once in a while, but it was at least usable. However, with the newest updates to Ubuntu, it's now completely stable. I don't know if it's a combination of this solution and the updates or only the updates, but if anyone is having the same problems with an updated version of Ubuntu, this is worth trying. :) Thanks a lot! – Stein Arne Brekke Feb 26 '15 at 8:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.