8

I'm reasonably tech savvy but very new to Ubuntu and I'm having a problem when watching video.

I can watch something for 15 minutes or so whether it be flash based or MP4 or something then Ubuntu just freezes for around 20 seconds then restarts. My system config is as follows:

  • i5-760 @ 2.8Ghz (stock)
  • 1x4GB Corsair Vengeance LP 1600Mhz
  • ASRock P55 Deluxe
  • Palit GTX 460 1GB @ stock (around 700Mhz I think)
  • 128GB Crucial M4
  • 500GB Hard drive, think it's a Samsung
  • Seasonic X-560 560W PSU

Software is Ubuntu 14.04, VLC Media Player, Mozilla Firefox, BBC iPlayer and the 'videos' app.

  • First I thought it might be overheating so I've checked my temps when playing video and it only gets to around 45-50c for the CPU and around 50-55c for the GPU. That's actually quite good so that can't be the problem.

  • Next I thought it may be a driver issue but I've downloaded the latest driver from Nvidia and I'm still having issues. I'm on version 304.123. Are there any alternative drivers I should be looking at?

  • Next I thought it could be a problem with my media or media player but I've tried different types of media in different media players and they all have the same issue. I used to run this PC in Windows for years and never had this issue so it's probably not a hardware problem.

  • Beyond that, I don't really know what to check. My motherboard or graphics card could have compatibility problems with Ubuntu but I don't think that's likely. This sort of thing can sometimes be a problem with the PSU as well but although this one is around 3 years old, it is really good quality and has plenty of power for my components.

The only thing I can see from the system log that looks like an error from the time of the crash is:

Sep 29 20:05:11 james-pc gnome-session[1293]: GLib-CRITICAL: g_environ_setenv: assertion 'value != NULL' failed

Any ideas on what to try next? Thanks in advance!

UPDATE: I've tried a memtest as well for 9 hours straight and it picked up no errors. I've also found that this doesn't just happen with video. It has happened a couple of times with games as well and even once or twice when i've just opened the software centre. Any other ideas? :(

UPDATE 2: Another error I have now seen is: [1412198417.432596] [nm-dns-dnsmasq.c:396] update(): dnsmasq owner not found on bus: Could not get owner of name

and

kernel: [ 6.990059] init: plymouth-splash main process (1140) terminated with status 1

  • Not sure if this is any help, but a google on the error report brings up these possibly similar experiences... askubuntu.com/questions/474281/… bbs.archlinux.org/viewtopic.php?id=180933 ... Perhaps you've added a disagreeable applet recently? – Tony Martin Sep 30 '14 at 23:14
  • You may be right, he seems to have an error with 'network manager'. I don't really understand what that is because I didn't knowingly install an app like that but some of the rest of that system log says something about re-installing network manager. The only things I have knowingly changed about my network is that I have added a VPN. – JMSellars1 Oct 1 '14 at 20:40
  • Just to clarify, when you say freezes then restarts, do you mean reboots or settles down to displaying the video? – Tony Martin Oct 2 '14 at 3:30
  • I mean it reboots. Further update as well, I've tried removing any unnecessary hardware such as my wi-fi card and sound card and doing a clean install and I still get the same issue except this time it is after 30-40 mins instead of 10-20 – JMSellars1 Oct 2 '14 at 17:20
  • have you run dmesg after it fails and you restart? scroll back, there may be some errors visible. this does, however, have the characteristics of a CPU/GPU overheating or a short-circuit. – tedder42 Oct 2 '14 at 20:15
1

Try checking the Brightness & Lock in the System Settings, it sounds like it is set to 15 minutes, if there is no key or mouse/touch pad movement detected after 15 minutes the screen will go into "sleep mode" usually blanking the display. You can set it a suitable time-out so it doesn't occur too early or turn it off. It applies what ever program is running so it will happen if you are watching a film or video longer than the time-out time.

  • Sorry I forgot to say, I did try this as well. That's not the problem. Thanks for the suggestion though. – JMSellars1 Oct 1 '14 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.