I'm trying to get Bamboo Pad working on Ubuntu 14.04

  1. I am sure that device is not broken = I can see it via lsusb
  2. All "howtogetyourwacomtabletworking" guides are designed for older versions of Ubuntu (below 14.04 version). That means that there is always some step which is not working.

    ...to illustrate this irritating situation some guides recommend to install wacom-dkms package.

    sudo add-apt-repository ppa:doctormo/wacom-plus sudo apt-get update sudo apt-get install wacom-dkms

However, there is no "wacom-dkms" package in that PPA, and, in fact, no packages for 14.04 at all (as I know from @mikewhatever, although I have no slightest idea what PPA is). So I began to believe (after hours of googling how to solve this problem) that there is maybe no driver on 14.04.

  1. I tried this as my last chance (but error again):

What this means?

Here is full script I've run.

ladislav@Skynet:~/Plocha$ cd input-wacom-0.23.0
ladislav@Skynet:~/Plocha/input-wacom-0.23.0$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc understands -c and -o together... yes
checking for style of include used by make... GNU
checking dependency style of gcc... none
checking for kernel type... Linux
checking for linux-based kernel... yes
checking for kernel source/headers... /lib/modules/3.13.0-37-generic/build
checking kernel version... 3.13.0-37-generic

checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating Makefile
config.status: creating 2.6.30/Makefile
config.status: creating 2.6.36/Makefile
config.status: creating 2.6.38/Makefile
config.status: creating 3.7/Makefile
config.status: creating config.h
config.status: executing depfiles commands
make  all-recursive
make[1]: Entering directory `/home/ladislav/Plocha/input-wacom-0.23.0'
Making all in 3.7
make[2]: Entering directory `/home/ladislav/Plocha/input-wacom-0.23.0/3.7'
    Building input-wacom drivers for 2.6 kernel.
make -C /lib/modules/3.13.0-37-generic/build M=/home/ladislav/Plocha/input-wacom-0.23.0/3.7
make[3]: Entering directory `/usr/src/linux-headers-3.13.0-37-generic'
  LD      /home/ladislav/Plocha/input-wacom-0.23.0/3.7/built-in.o
  CC [M]  /home/ladislav/Plocha/input-wacom-0.23.0/3.7/wacom_wac.o
  CC [M]  /home/ladislav/Plocha/input-wacom-0.23.0/3.7/wacom_sys.o
  LD [M]  /home/ladislav/Plocha/input-wacom-0.23.0/3.7/wacom.o
  CC [M]  /home/ladislav/Plocha/input-wacom-0.23.0/3.7/wacom_w8001.o
  Building modules, stage 2.
  MODPOST 2 modules
  CC      /home/ladislav/Plocha/input-wacom-0.23.0/3.7/wacom.mod.o
  LD [M]  /home/ladislav/Plocha/input-wacom-0.23.0/3.7/wacom.ko
  CC      /home/ladislav/Plocha/input-wacom-0.23.0/3.7/wacom_w8001.mod.o
  LD [M]  /home/ladislav/Plocha/input-wacom-0.23.0/3.7/wacom_w8001.ko
make[3]: Leaving directory `/usr/src/linux-headers-3.13.0-37-generic'
make[2]: Leaving directory `/home/ladislav/Plocha/input-wacom-0.23.0/3.7'
make[2]: Entering directory `/home/ladislav/Plocha/input-wacom-0.23.0'
make[2]: Leaving directory `/home/ladislav/Plocha/input-wacom-0.23.0'
make[1]: Leaving directory `/home/ladislav/Plocha/input-wacom-0.23.0'

----------------------------------------
  BUILD ENVIRONMENT:
       linux kernel - yes 3.7
      kernel source - yes /lib/modules/3.13.0-37-generic/build

Your wacom.ko is available under 
    /home/ladislav/Plocha/input-wacom-0.23.0/3.7
If you have an USB device, you can copy the driver by:
    cp 3.7/wacom.ko /lib/modules/3.13.0-37-generic/kernel/drivers/input/tablet
If you have a serial device, please copy the driver by:
    cp 3.7/wacom_w8001.ko /lib/modules/3.13.0-37-generic/kernel/drivers/input/touchscreen

NOTE: The kernel drivers included in this package are only
tested with the X Wacom driver built from xf86-input-wacom.
 If you are running an X server version older than 1.7, 
please use the drivers provided by linuxwacom package.

ladislav@Skynet:~/Plocha/input-wacom-0.23.0$ cp 3.7/wacom.ko /lib/modules/3.13.0-37-generic/kernel/drivers/input/tablet
cp: nie je možné vytvoriť obyčajný súbor ( = Is not possible to create "ordinary" file)  `/lib/modules/3.13.0-37-generic/kernel/drivers/input/tablet/wacom.ko': Prístup odmietnutý ( = Access denied)

here is my lsusb output:

ladislav@Skynet:~$ lsusb
Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0930:0220 Toshiba Corp. 
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader
Bus 003 Device 003: ID 12d1:1c08 Huawei Technologies Co., Ltd. 
Bus 003 Device 007: ID 056a:0319 Wacom Co., Ltd 
Bus 003 Device 005: ID 04ca:7018 Lite-On Technology Corp. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Does anybody know how to solve this? Any giude for 14.04 will be helpful.

  • There is no "wacom-dkms" package in that PPA, and, in fact, no packages for 14.04 at all. Just move to the next step of the wiki. – mikewhatever Sep 29 '14 at 17:53
  • Thank you @mikewhatever! I moved to the next step but got another error: "unable to locate package wacom-tools". I tried to skip this second error, but device is still unrecognized. Is there some guide for installing "Bamboo" driver on 14.04? It is even possible now? – Ladislav Naďo Sep 29 '14 at 18:13
  • Well, it says "Note: wacom-tools is not available from 10.04, replace with xserver-xorg-input-wacom instead." Are you sure it doesn't work? Have you tried the built in Application yet? – mikewhatever Sep 29 '14 at 19:05
  • Still not working. I replaced wacom-tools with xserver....etc. What do you mean by "built in Application"? You mean "Tablet Wacom" in application menu? If yes, I cheched it and it still can not find tablet (but I can see it via "lsusb"). Is there any "diagnostic" command to check what is wrong? – Ladislav Naďo Sep 29 '14 at 19:44
  • Right, so which part of the compilation didn't work? ...or do you mean, it compiled, but the tablet is not recognized? You should add the output of lsusb to the question. – mikewhatever Sep 29 '14 at 20:41
up vote 9 down vote accepted
+50

I felt the need to make another answer because of differing conditions, which appeared in chat.

This is a known bug.
Status: In Progress (since 1/03/2014)
Importance: Medium
Bug info up-to-date as of 01/30/2017.

The workaround offered in Post 38 of said bug report works.

An easier-to-understand version:

  1. Run lsusb and get the Wacom device code. (In this example, 056a:0319) Add 0x to both strings. (With our example 0x056a and 0x0319). If your device is not on the below list, this solution may not work! Though unlikely, this may break your system. You have been warned.
  2. Open Gedit by running gksudo gedit /etc/default/grub
  3. Look for the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash".
  4. Change it to this (Replace the 0x056a and 0x0319 with whatever you got in Step 1):
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbhid.quirks=0x056a:0x0319:0x40000000"
    Save and close Gedit.
  5. Don't forget to run
    sudo update-grub
    after you change grub!!!
  6. Reboot. If it works, DO NOT GO ANY FURTHER.
  7. Open Gedit again by running gksudo gedit /usr/share/X11/xorg.conf.d/50-wacom.conf. Paste the data from this link into it and save.
  8. Reboot once again. Again, if it works, DO NOT GO ANY FURTHER!
  9. If it still doesn't work, follow the git method from this link. Please note that you need to install Git if you don't have it already: sudo apt-get install git-core.
  10. Reboot.

Steps 1-5 are confirmed to work for the following devices:

  • 056A:0318 -- Wired Bamboo Pad
  • 056A:0319 -- Wireless Bamboo Pad

Devices not on this list have not been tested and may not work. Use at your own risk! If a device not on this list worked for you, please add it to the above list.

  • This worked for me, but I had to check @conspirito 's tip and use the correct id. – t3mujin Nov 16 '14 at 15:54
  • Steps 1 - 5 get the stylus part working fine, but the trackpad part still doesn't seem to work. I followed the rest of the instructions, but they didn't help. Any ideas? – kleinric Dec 10 '14 at 9:04
  • @kleinric Use lsusb and determine the proper code. If the code is correct, please open a new question! – Kaz Wolfe Dec 10 '14 at 18:08
  • @kleinric I simply added MatchIsTablet "on" to most of the Wacom entries in the file mentioned in step 7 and everything seems to work just fine for my Wacom Bamboo Pad CTH-300 (wireless). – Arno Moonen Jan 20 '15 at 9:07
  • 1
    Same as @ArnoMoonen: After following all steps in this answer the stylus was working but not touchpad. Bamboo Pad would appear in the Wacom Tablet dialog in System Settings, but touching it or clicking the buttons did nothing. Then I added MatchIsTablet "on" to all wacom Sections in 50-wacom.conf and now everything seems to be working perfectly. It would be great to add this into the answer. – Sean Hammond May 10 '15 at 13:10

--- THIS ANSWER DOES NOT SOLVE THE PROBLEM! Use my above answer instead! ---

AHA!

Your problem is in this line, right here:

cp: -snip- Access denied

Try using:

sudo cp 3.7/wacom.ko /lib/modules/3.13.0-37-generic/kernel/drivers/input/tablet

Also make sure that the xf86-input-wacom package is installed. If not, use this handy link:

Install via the software center

Reboot and enjoy!

  • Hi @Whaaaaaat. Now, command you recommended worked = no error this time. However, nothing has changed - bamboo still not working. I have the xf86-input-wacom installed (newest available version). Any suggestions? – Ladislav Naďo Oct 1 '14 at 18:04
  • I rebooted, still nothing. I have also installed everything from "ubuntu apps directory" = (searched with keyword (wacom) = 9 results = all of them I have installed. But is peculiar that when you filter those 9 results to only Ubuntu 14.04 Trusty (click on left side on the results page) you will find that nothing is available for 14.04. – Ladislav Naďo Oct 1 '14 at 18:24
  • What happens if you modprobe tablet? (curiosity only) – Kaz Wolfe Oct 1 '14 at 18:28
  • ladislav@Skynet:~$ modprobe tablet modprobe: FATAL: Module tablet not found. – Ladislav Naďo Oct 1 '14 at 18:30
  • k. don't know what I was expecting, to be honest... – Kaz Wolfe Oct 1 '14 at 18:30

Changing grub, as described from Whaaaaaat (point 1-5), worked for me (12.04 and 14.04), great, thanks, however only after adapting the ID from lsusb output: My example lsusb output:

Bus 002 Device 005: ID 056a:0318 Wacom Co., Ltd

this means we need to adapt the ID from:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbhid.quirks=0x056a:0x0319:0x40000000"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbhid.quirks=0x056a:0x0318:0x40000000"

Summary: Check your lsusb wacom ID prior to change GRUB_CMDLINE_.....

  • This was what was missing! Worked for me – t3mujin Nov 16 '14 at 15:55

It seems like this tablet's been around for a while with no sign of resolution from Ubuntu. The marked fix works well for getting basic stylus functionality going, but in some cases it does not enable the stylus button (so no right click), and it does not enable the buttons on the pad or the touchpad functionality.

A reply on the bug report claims to have gotten full functionality, including touchpad, by editing /usr/share/X11/xorg.conf.d/50-wacom.conf to add MatchIsTablet:

MatchProduct "Wacom|WACOM|Hanwang|PTK-540WL|ISD-V4"
MatchIsTablet "on"

I haven't had success with it myself but it might make a difference for others depending on configuration.

What I finally wound up doing was to create a UNetbootin Live USB Flash Drive from an older Ubuntu 14.04.1 LTS Desktop ISO which I had made back in 2013. And installed from that. In that Older Ubuntu kernel incarnation, the Wacom Bamboo Pen Tablet was still recognized. so that I could set its 'System Settings' Tablet GUI to set the Mouse Emulation Mode and Reassign the Stylus Key functions. I then still needed to implement Mouse Pointer Acceleration in order to obtain correct Tablet functioning., But that older hardware function is also disabled in newer incarnations of Ubuntu, even in 14.04.01. So, because xorg commands which are entered from 'Terminal' are not retained on reboot. I added an xset entry to Startup Applications from the ('Console' located at the Top of the Unity bar) ' xset m 6 1 ' And labeled that MouseAcceleration. (m indicates Mouse, and the first number 6 being the acceleration factor). After this and other System Settings had been completed, I then installed the Ubuntu Updates to bring the older Kernel up to speed.

Previous to this on a 14.05.5 Live USB with Persistence, I tried the steps outlined above, but no joy. Steps 1 through 5 could not be retained because sudo update-grub only returned could not write to /cow

and the ' gksudo gedit /usr/share/X11/xorg.conf.d/50-wacom.conf ' option, only returned an entry list which was already precisely the same as the referenced list.

It was at this point that I decided to go with what I wound up doing.

As a previous Windows user, what initially sold me on giving Ubuntu Linux a try to begin with, was Leo Lapport (a few years back) on his The Tech Guy radio program stating that Linux and especially Ubuntu Linux had retained Native Drivers for Older computer hardware in their Kernels. Making it possible for the disadvantaged to get some useful life out of older and outdated computers that would otherwise be junked. In that respect, its very sad to see them now stripping out so much native support for the older drivers.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.