I have a clean installation of Ubuntu 14.04 and in my /etc/cron.daily/ I see *.disabled files:

-rwxr-xr-x 1 root root 15481 Apr 10 09:04 apt.disabled
-rwxr-xr-x 1 root root   314 Feb 17  2014 aptitude.disabled
-rwxr-xr-x 1 root root   355 Jun  4  2013 bsdmainutils.disabled
-rwxr-xr-x 1 root root   384 Mar 23  2014 cracklib-runtime.disabled
-rwxr-xr-x 1 root root   256 May  1 08:29 dpkg.disabled
-rwxr-xr-x 1 root root   372 Jan 22  2014 logrotate
-rwxr-xr-x 1 root root  1261 Apr 10 06:59 man-db.disabled
-rwxr-xr-x 1 root root   435 Jun 20  2013 mlocate.disabled
-rwxr-xr-x 1 root root   249 Feb 16  2014 passwd.disabled
-rwxr-xr-x 1 root root   349 Dec 27  2012 quota.disabled
-rwxr-xr-x 1 root root   322 Apr 11 17:58 upstart.disabled

Why is this happening? I want to use unattended-upgrades on my box, but documentation for unattended-upgrades indicates I need to edit /etc/cron.daily/apt file. According to this link I believe that file should exist by default: http://pkgs.org/ubuntu-14.04/ubuntu-main-amd64/apt_1.0.1ubuntu2_amd64.deb.html (and not apt.disabled?)


We encounter the same problem with one VPS server which is hosted at a provider using OpenVZ (https://openvz.org). Another server with fresh 14.04 install (hosted elsewhere) has all cron jobs enabled.

My best guess is that it is a try of the provider to save some system resources.

| improve this answer | |

Further to Ikar's answer, we have also seen this on a VPS provider using https://openvz.org/.

We addressed it by running this bash script:

for script in $(find /etc/cron.* -type f -name '*.disabled' ! -name '.placeholder*')
    mv "$script" "$(dirname $script)/$(basename $script .disabled)"

which simply strips all the ".disabled" off the standard cron scripts provided by the VPS host.

| improve this answer | |

We've also seen this on OpenVZ VMs running Debian. The OpenVZ provided templates/images have all cronjobs from /etc/cron.* disabled by default.

I have no clue why they did that, but it seems that this issue is caused by the template/image used and has nothing to do with any particular VPS provider.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.