0

I'm experiencing the following problem.

I was asked from the system to update to 14.04 version of Ubuntu and I confirmed it. While it was working, the installation was giving few errors and continuing but suddenly it stopped. I cannot remember what it was installing and maybe I did a mistake but I killed the process. Now to restart the installation I googled it and found people saying simply to update and upgrade the system. But now when I give the command:

sudo apt-get update

I get the follwoing error:

apt-get: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.17' not found (required by /usr/lib/x86_64-linux-gnu/libstdc++.so.6)

I don't want to destroy my computer and I have important files. How can I face this problem? I could also back to the previous Ubuntu version but I don't know if how to do it safely.

Please give me an help!

0

You don't have a high enough version of libc6, that is causing the error.

From How to fix “/lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found”? – Super User:

That means the program was compiled against glibc version 2.14, and it requires that version to run, but your system has an older version installed. You'll need to either recompile the program against the version of glibc that's on your system, or install a newer version of glibc (the "libc6" package in Debian).

So, you just need to upgrade your libc6 package. All versions of Ubuntu have at least version 2.15 because it's a faily important package (reference).

To upgrade it, use these commands in a terminal:

sudo apt-get install libc6
sudo apt-get update

I hope this is help you.

  • ..unfortunately the command: "sudo apt-get install libc6" also produces the error:_" apt-get: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.17' not found (required by /usr/lib/x86_64-linux-gnu/libstdc++.so.6)" – Angelo Ulivieri Sep 29 '14 at 11:17
  • you followed this link superuser.com/questions/537683/… – DreamCoder Sep 29 '14 at 11:19
  • I just installed the packages and run this command: LD_LIBRARY_PATH=/home/angelo/fakeroot/usr/lib/x86_64-linux-gnu/ apt-get install libc6 - but I'm having the same problem. Maybe this command is wrong? – Angelo Ulivieri Sep 29 '14 at 11:27
  • I just used the command with the previous command bu I'm getting another error: /usr/bin/python: error while loading shared libraries: __vdso_time: invalid mode for dlopen(): Invalid argument. What does this means? There are conflicts between partially installed operating systems? How can I solve? Need formatting and re-installation? – Angelo Ulivieri Sep 29 '14 at 13:04

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.