0

Kubuntu 14.04 on a new computer. GPU is R9 280x in case it's relevant.

Sometimes (not every time) when I restart in order to switch to Windows, Kubuntu seems to hang. There's a black screen. I am able to change to Ctrl+Alt+F1 and get a login prompt, but I can't do anything with it (the keyboard is not responsive). So I cannot inspect the state of the machine (processes etc.) when this happens. Pressing Ctrl+Alt+F7 again I continue to see the tty1 login prompt, but it seems to be just painted remains (no blinking cursor).

Following answers to similar questions, I tried REISUB (with a few seconds after each letter), but it only prints some messages about USB devices to tty1, and nothing else. In particular, it does not reboot the machine, the only thing that seems to work is a hard reset.

I do not see any information from the relevant time in syslog, dmesg and kern.log, except rsyslogd: [...] exiting on signal 15.

How can I troubleshoot this problem?

Thank you.

Edit - more information:

  • I initially tried only rebooting from the menu, but the problem also happens with sudo shutdown -r now.
  • The physical power buttons work as expected.
  • Ctrl+Alt+Del/Delete does not do anything in the hung state.
  • I have not reproduced the problem when halting instead of restarting. The problem happens when halting as well.
  • My system is up to date.
  • I waited a few minutes in the hung state before trying REISUB in tty1. Some new information appeared, I took a picture. Everything between "INFO" until the end of the call trace wasn't there before, I guess it only appears if you wait. This time, Alt+SysRq+B did work.
  • Removing the module 8192cu seems to work. However, it is my wifi card driver, so I need it. I have TP link 822n card. It works out of the box on Ubuntu, but disconnects after a while, so I had to follow this guide.
  • how do you restart? using the menu or by running sudo shutdown -r now from console? what happened when you press the power button of the machine? does this happened only on restart? what happened when you just shutdown? are you sure the system is updated? run sudo apt-get update && sudo apt-get dist-upgrade and make sure everything is updated. – Ohad Cohen Oct 1 '14 at 12:47
  • @OhadCohen I've added this information to the post, thanks. – meadow Oct 1 '14 at 15:46
  • a shot in the dark: run sudo rmmod rtl8192c before shutting down – Ohad Cohen Oct 1 '14 at 21:40
  • @OhadCohen Thanks, that seems to work! However it is the wifi driver. Is it a good idea to try and automate its removal? What else can I do? – meadow Oct 5 '14 at 11:46
0

So, after some discussions in the comments we found it's a problem in the wifi driver. The right way is to file a bug in the linux kernel bug tracker, or Ubuntu Kernel Team Bug Tracker.

Since you seems like a developer who make things as strait as possible, you can try to find the bug and fix it yourself - get the kernel source using git, fix the bug in the driver (i never tried to send code to the kernel, good luck).

meanwhile you can use that workaround - just unload the kernel module before you shutdown your system. You can take a look at this answer on how to automate it. I see no reason to be afraid doing this. (the module is meant to be unloaded at shutdown anyway)

  • I'll consider those. Thank you very much. – meadow Oct 5 '14 at 20:42
0

this guy has similar problem and he seems to found the reason and solve it.

hope it will work for you too.

  • Thanks, but I haven't found such settings in the login screen, and in any case, given that the problem still exists with sudo shutdown -r now, his post is not relevant here, I think? – meadow Oct 1 '14 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.