I'm new here using ubuntu and I installed 14.04 LTS. I'm trying to install a driver of TF-3200 TP-LINK and unfortunately I can't figure how to do it. I've search all over the internet and also refer to the CD of TP-LINK.

  • Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. Oct 11, 2014 at 8:45

1 Answer 1


Check this link http://ubuntuforums.org/showthread.php?t=2166743. You can download the drivers here: http://www.tp-link.us/products/details/?categoryid=&model=TF-3200#down

1- I extracted all the files from the zip and browsed the directory:

user1@host1:~/Downloads$ cd TF-3200_100628/
user1@host1:~/Downloads/TF-3200_100628$ ls
LinuxDriver       Windowns 7 64bit  Windows ME           Windows XP_2003
Novell Netware    Windows 2000      Windows Vista 32bit  Windows XP 64bit
Windowns 7 32bit  Windows 98SE      Windows Vista 64bit

user1@host1:~/Downloads/TF-3200_100628$ cd LinuxDriver/

user1@host1:~/Downloads/TF-3200_100628/LinuxDriver$ ls
compat.h  ethtool.h  mii.c  readme.txt
crc32.h   Makefile   mii.h  sundance_main.c

2- Loaded the kernel module drivers:

user1@host1:~/Downloads/TF-3200_100628/LinuxDriver$ sudo modprobe mii; sudo modprobe sundance;

3- Verify how if it loaded correctly; I have no card, so I'm not able to see it in dmesg. You should, though.

user1@host1:~/Downloads/TF-3200_100628/LinuxDriver$ dmesg | grep -i eth | tail
[    0.104998] reboot: Dell xxx xxx series board detected. Selecting PCI-method for reboots.
[    3.998768] tg3 0000:0a:00.0 eth0: Tigon3 [partno(BCM95761) rev 5761100] (PCI Express) MAC address d0:67:e5:56:d0:b9
[    3.998777] tg3 0000:0a:00.0 eth0: attached PHY is 5761 (10/100/1000Base-T Ethernet) (WireSpeed[1], EEE[0])
[    3.998783] tg3 0000:0a:00.0 eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
[    3.998788] tg3 0000:0a:00.0 eth0: dma_rwctrl[76180000] dma_mask[64-bit]
[   39.375507] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   47.558954] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   49.294698] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   49.295255] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready

Same in ip link details:

user1@host1:~/Downloads/TF-3200_100628/LinuxDriver$ ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
    link/ether d0:67:e5:00:00:00 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000
    link/ether 60:67:20:00:00:40 brd ff:ff:ff:ff:ff:ff
  • I already tried this one but I can't find the exact installation of the driver. it's not like in windows that you can click the driver installer or browse it. I tried all the terminal commands here but unfortunately nothing works. Sep 30, 2014 at 0:25
  • I tried to run the procedure as mentioned in xaie.wordpress.com/2011/10/07/tp-link-tf-3200-on-debian; Apparently no error. I edited my answer with the procedure I used. what’s the result of ifconfig and route? also, what do you have defined in /etc/network/interfaces and /etc/resolv.conf. Oct 9, 2014 at 8:50

Not the answer you're looking for? Browse other questions tagged .