1

Since bash was updated very recently, when I try to autocomplete by tabbing during a cd I get the following...

tony@tony-HP:~$ cd Mucword=1
words[0]=${!ref}${COMP_WORDS[i]}
words[1]=${!ref}${COMP_WORDS[i]}
cword=1
words=("${@:3:2}")
cword="$3"
cur="$3"
cur="$3"
cword="$3"
prev="$3"
words=("${@:3:2}")
 compgen -d -- "$quoted" 
sic/

Here I've typed cd Mu at the prompt and tabbed and, after bash vomits the information I don't require adds sic/ after identifying my Music directory. What's changed? Is there a setting that has been defaulted otherwise following the security problems?

p.s. Hitting return changes directory as you'd expect.

6

I know the question is a bit old but I will answer in case someone has the same problem. This can be fixed by typing 'bash +v' in a terminal. You probably typed 'bash -v' trying to see the bash version (like I did) but this does something else instead. P.S. to see the bash version use 'bash --version'

1

Well, that answer is now also a bit old. However, it helped me, but it's also wrong. That said, it lead me to the solution, so thanks, Babis.

Running bash +v starts a new shell on top of the old one.

If you want to modify the behavior of your current shell, use the "set" command:

set +v

This tells bash to turn off printing input lines as they are read, the source in this case being the bash completion functions.

Amusingly, I ran into this in cygwin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.