1

About a year ago I installed Ubuntu 12.04 and the touchpad never worked and as a result I never used ubuntu I just upgraded to 14.04 thinking it might work and the touchpad still doesn't work.

I have tried disabling the acer wim files, editing the xorg.conf, using all the F Keys at the login screen and installing drivers with dkms that I found here

When I run cat proc/bus/input/devices I find this

I: Bus=0011 Vendor=0002 Product=000e Version=0000 N: Name="ETPS/2 Elantech Touchpad" P: Phys=isa0060/serio2/input0 S: Sysfs=/devices/platform/i8042/serio2/input/input10 U: Uniq= H: Handlers=mouse1 event6
B: PROP=5 B: EV=b B: KEY=e420 0 10000 0 0 0 0 0 0 0 0 B: ABS=6618000 11000003

0

Hello Linuxers I see many problems with the Elantech Touchpad sites in the world. A clear solution was included in the kernel ubuntu 3.18. I installed ubuntu 14.10 (formerly the beta and now the clean final version) with an ultrabook ETPS / 2 Elantech Touchpad hardware that works in W8 but precariously as PS2 mouse in ubuntu. I downloaded the new kernel ubuntu 3.18, installed and after reboot everything is working. But, open System Settings> Mouse & Touchpad> Touchpad and see the visible section to enable a> Natural Scrolling

  • 1
    A guide on how to install Kernel 3.18 would be nice. – MadMike Oct 27 '14 at 6:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.