0

I've installed ssmtp and configured /etc/ssmtp.conf file and can successfully send outgoing emails, but I cannot send anything internally, i.e. whenever I type mail sergiy, which is my actual username on the machine, I can write and send a message, but I still get "No new mail".

Then a few minutes later postmaster in my actual, web-based mail will send a "Delivery Status Notification(Failure)" message. Neither mail sergiy@localhost works.

Basically, I want to be able to receive mail on my laptop, not just send it.

I know I can check my web mail with mutt -f imaps://user@imapserver.example.com, but this is not what I'm trying to accomplish here.

Also, I've been getting emails of this type when I have root equal to my email address (in the file /etc/ssmtp/ssmpt.conf):

Subject: Cron <smmsp@sergiy-Satellite-L455D> test -x /etc/init.d/sendmail && /usr/share/sendmail/sendmail cron-msp

And here is the message itself:

/usr/share/sendmail/sendmail: 899: /usr/share/sendmail/sendmail: /usr/sbin/sendmail-msp: not found

What does cron keep complaining about here?

Additional information: According to this page (namely system mail) if you execute mail user, mailx assumes localhost, so you should be able to mail yourself or another user on your system. On my laptop neither my account, nor another account can receive mail if I do it this way.

1

If you installed more than one MTA on your system, now or in the past, you might have leftovers of those installs. As suggested elsewhere, try:

   sudo apt-get purge sendmail sendmail-bin

Make sure that the following dependencies - sendmail-base,sendmail-cf and sendmail-bin - are removed. Then reinstall sendmail.

If you have Postfix installed, you may not need to reinstall sendmail-bin.
HTH

FOLLOW-UP: sSMTP is only meant to send email to a mail hub. To the best of my knowledge you cannot use it for anything else. So, either you setup your machine as a mail server or you start using an outside mail hub. Installing PostFix would be a way of acheiving what you want though. If you do so I would recommend you first uninstall ssmtp.

| improve this answer | |
  • I tried to remove sendmail as you suggested. The output is this: Package 'sendmail' is not installed, so not removed. In fact, in Ubuntu Software Center it says sendmail not installed, and if i try to install, it says i need to remove ssmtp. Postfix isn't installed either. My plan is to try installing it tomorrow and configure, and see what happens. – Sergiy Kolodyazhnyy Sep 29 '14 at 9:45
  • See Follow-Up 1. – Cbhihe Sep 29 '14 at 13:53
  • Follow-UP 1 -> FOLLOW-UP – Cbhihe Sep 29 '14 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.