I recently uninstalled LibreOffice to install OpenOffice and experienced no problems in using Open Office. Later, I installed a file preview software known as Sushi. When trying to view .odp files, Sushi stated that it needed additional software to preview those files. I went ahead with the download, and it installed packages relating to Libreoffice which are in conflict with the OpenOffice packages. When I try to install software, I cannot download anything; this is the error message that I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libreoffice-core : Depends: libreoffice-common (> 1: but it is not installed
 libreoffice-help-en-us : Depends: libreoffice-l10n-en-us
 libreoffice-l10n-en-gb : Depends: libreoffice-common but it is not installed
 libreoffice-l10n-en-za : Depends: libreoffice-common but it is not installed
E: Unmet dependencies. Try using -f.

I've tried using -f both before and after the install in terminal as well as unchecking all options in the "other software" section of "software & updates." (getting error messages which I could post here for clarification if asked) I've tried clearing the software cache out using "clean" and "autoclean" as well as purging OpenOffice and the libreoffice-core to no avail.

Any suggestions as to what to do? Everything else on the system works very smoothly. I just can't do updates.

I'm fairly new to Ubuntu and command line, very much a rookie. With that being said, is there a way to uninstall recent updates (as shown in "History" in Software Center)? I have little data on the computer and wouldn't mind wiping it either as a last resort and doing a fresh install. (but I don't know how to while keeping it as a dual boot machine with Win 8)


1 Answer 1


I fixed it! I found the solution here:

trying to overwrite 'file', which is also in package '*', how to solve?

I removed the package that needed to be overwritten (as listed in the command line), and it got rid of OpenOffice and reinstalled LibreOffice. The software said that my computer was up-to-date, so that fixed it.

Not the answer you're looking for? Browse other questions tagged .