2

I recently installed okular using the ubuntu software center, but I haven been able to use it yet, once i run the program and I choose open document it crashes. This appears to me in the command line while okular is opened until it crashes.

sebas@PinkFloyd92-:~/Downloads/1001 Libros Digitales/1000 Libros Digitales$ okular
okular(6589)/kdeui (KIconLoader): Error: standard icon theme "oxygen" not found! 

okular(6589)/kdeui (KIconLoader): Error: standard icon theme "oxygen" not found! 

okular(6589) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(6589) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(6589) KPixmapSequence::frameSize: No frame loaded 
okular(6589) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(6589) KPixmapSequence::frameSize: No frame loaded 
okular(6589) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(6589) KPixmapSequence::frameSize: No frame loaded 
okular(6589) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(6589) KPixmapSequence::frameSize: No frame loaded 
okular(6589) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(6589) KPixmapSequence::frameSize: No frame loaded 
okular(6589) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(6589) KPixmapSequence::frameSize: No frame loaded 
okular(6589): No ksycoca4 database available! 

okular(6589)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "okular/Generator"  not found 
okular(6589)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(6589)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(6589)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(6589)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(6589)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(6589)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:    
okular(6589): No ksycoca4 database available!     

okular(6589)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader:     serviceType  "KParts/ReadOnlyPart"  not found      
okular(6589): No ksycoca4 database available!       

okular(6589)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader:     serviceType  "KParts/ReadOnlyPart"  not found      
okular(6589) fileModule: Failed to load configured file module "kfilemodule"     
KCrash: Application 'okular' crashing...      
KCrash: Attempting to start  from kdeinit     
sock_file=/home/sebas/.kde/socket-PinkFloyd92-/kdeinit4__0    
Warning: connect() failed: : No such file or directory    
KCrash: Attempting to start  directly   
KCrash failed to exec(), errno = 2    
Unable to start Dr. Konqi    
Not forwarding the crash to Apport.

Now this appears:

sebas@PinkFloyd92-:~$ sudo dpkg --configure -a --force-all
sebas@PinkFloyd92-:~$ sudo apt-get clean
sebas@PinkFloyd92-:~$ sudo apt-get update 
Ign http://dl.google.com stable InRelease
Hit http://dl.google.com stable Release.gpg                                    
Ign http://security.ubuntu.com trusty-security InRelease                       
Ign http://download.tuxfamily.org trusty InRelease                             
Hit http://dl.google.com stable Release                                        
Hit http://security.ubuntu.com trusty-security Release.gpg                     
Hit http://repo.steampowered.com precise InRelease                             
Ign http://download.tuxfamily.org trusty Release.gpg                           
Hit http://dl.google.com stable/main amd64 Packages                            
Ign http://ppa.launchpad.net trusty InRelease                                  
Hit http://security.ubuntu.com trusty-security Release                         
Ign http://download.tuxfamily.org trusty Release                               
Hit http://dl.google.com stable/main i386 Packages                             
Ign http://ppa.launchpad.net trusty InRelease                                  
Hit http://security.ubuntu.com trusty-security/main Sources                    
Ign http://ppa.launchpad.net trusty InRelease                                  
Hit http://security.ubuntu.com trusty-security/restricted Sources              
Hit http://repo.steampowered.com precise/steam Sources                         
Ign http://ppa.launchpad.net trusty InRelease                                  
Hit http://security.ubuntu.com trusty-security/universe Sources                
Hit http://security.ubuntu.com trusty-security/multiverse Sources              
Ign http://ppa.launchpad.net trusty InRelease                                  
Ign http://ec.archive.ubuntu.com trusty InRelease                              
Hit http://repo.steampowered.com precise/steam amd64 Packages                  
Hit http://security.ubuntu.com trusty-security/main amd64 Packages             
Ign http://ppa.launchpad.net trusty InRelease                                  
Hit http://security.ubuntu.com trusty-security/restricted amd64 Packages       
Ign http://ec.archive.ubuntu.com trusty-updates InRelease                      
Ign http://ppa.launchpad.net saucy InRelease                                   
Ign http://extras.ubuntu.com trusty InRelease                                  
Ign http://dl.google.com stable/main Translation-en_US                         
Hit http://security.ubuntu.com trusty-security/universe amd64 Packages         
Hit http://ppa.launchpad.net trusty Release.gpg                                
Ign http://dl.google.com stable/main Translation-en                            
Hit http://repo.steampowered.com precise/steam i386 Packages                   
Ign http://ec.archive.ubuntu.com trusty-backports InRelease                    
Hit http://extras.ubuntu.com trusty Release.gpg                                
Hit http://security.ubuntu.com trusty-security/multiverse amd64 Packages       
Hit http://ppa.launchpad.net trusty Release.gpg                                
Hit http://extras.ubuntu.com trusty Release                                    
Hit http://ec.archive.ubuntu.com trusty Release.gpg                            
Hit http://security.ubuntu.com trusty-security/main i386 Packages              
Hit http://ppa.launchpad.net trusty Release.gpg                                
Hit http://extras.ubuntu.com trusty/main Sources                               
Hit http://security.ubuntu.com trusty-security/restricted i386 Packages        
Hit http://ec.archive.ubuntu.com trusty-updates Release.gpg                    
Ign http://ppa.launchpad.net trusty Release.gpg                                
Hit http://security.ubuntu.com trusty-security/universe i386 Packages          
Hit http://extras.ubuntu.com trusty/main amd64 Packages                        
Hit http://security.ubuntu.com trusty-security/multiverse i386 Packages        
Hit http://ppa.launchpad.net trusty Release.gpg                                
Hit http://extras.ubuntu.com trusty/main i386 Packages                         
Hit http://security.ubuntu.com trusty-security/main Translation-en             
Hit http://ec.archive.ubuntu.com trusty-backports Release.gpg                  
Hit http://ppa.launchpad.net trusty Release.gpg                                
Hit http://security.ubuntu.com trusty-security/multiverse Translation-en       
Hit http://ppa.launchpad.net saucy Release.gpg                                 
Hit http://ec.archive.ubuntu.com trusty Release                                
Hit http://security.ubuntu.com trusty-security/restricted Translation-en       
Hit http://ppa.launchpad.net trusty Release                                    
Hit http://ppa.launchpad.net trusty Release                                    
Hit http://ec.archive.ubuntu.com trusty-updates Release                        
Hit http://security.ubuntu.com trusty-security/universe Translation-en         
Hit http://ppa.launchpad.net trusty Release                                    
Hit http://ec.archive.ubuntu.com trusty-backports Release                      
Ign http://ppa.launchpad.net trusty Release                                    
Hit http://ec.archive.ubuntu.com trusty/main Sources                           
Hit http://ppa.launchpad.net trusty Release                                    
Hit http://ec.archive.ubuntu.com trusty/restricted Sources                     
Err http://download.tuxfamily.org trusty/cairo-dock amd64 Packages             
  404  Not Found [IP: 88.191.250.171 80]
Hit http://ec.archive.ubuntu.com trusty/universe Sources                       
Hit http://ppa.launchpad.net trusty Release                                    
Err http://download.tuxfamily.org trusty/cairo-dock i386 Packages              
  404  Not Found [IP: 88.191.250.171 80]
Hit http://ec.archive.ubuntu.com trusty/multiverse Sources                     
Hit http://ppa.launchpad.net saucy Release                                     
Ign http://download.tuxfamily.org trusty/cairo-dock Translation-en_US          
Ign http://extras.ubuntu.com trusty/main Translation-en_US                     
Hit http://ec.archive.ubuntu.com trusty/main amd64 Packages                    
Hit http://ppa.launchpad.net trusty/main amd64 Packages                        
Ign http://download.tuxfamily.org trusty/cairo-dock Translation-en             
Ign http://extras.ubuntu.com trusty/main Translation-en                        
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Hit http://ec.archive.ubuntu.com trusty/restricted amd64 Packages              
Hit http://ec.archive.ubuntu.com trusty/universe amd64 Packages                
Hit http://ec.archive.ubuntu.com trusty/multiverse amd64 Packages              
Hit http://ppa.launchpad.net trusty/main amd64 Packages                        
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Hit http://ec.archive.ubuntu.com trusty/main i386 Packages                     
Ign http://repo.steampowered.com precise/steam Translation-en_US               
Hit http://ppa.launchpad.net trusty/main Translation-en                        
Hit http://ppa.launchpad.net trusty/main amd64 Packages                        
Hit http://ec.archive.ubuntu.com trusty/restricted i386 Packages               
Ign http://repo.steampowered.com precise/steam Translation-en     
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Hit http://ec.archive.ubuntu.com trusty/universe i386 Packages                 
Hit http://ec.archive.ubuntu.com trusty/multiverse i386 Packages               
Hit http://ec.archive.ubuntu.com trusty/main Translation-en                    
Hit http://ec.archive.ubuntu.com trusty/multiverse Translation-en              
Hit http://ppa.launchpad.net trusty/main amd64 Packages                        
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Hit http://ec.archive.ubuntu.com trusty/restricted Translation-en              
Hit http://ppa.launchpad.net trusty/main Translation-en                        
Hit http://ec.archive.ubuntu.com trusty/universe Translation-en                
Hit http://ppa.launchpad.net trusty/main amd64 Packages                        
Hit http://ec.archive.ubuntu.com trusty-updates/main Sources                   
Hit http://ec.archive.ubuntu.com trusty-updates/restricted Sources             
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Hit http://ppa.launchpad.net trusty/main Translation-en                        
Hit http://ec.archive.ubuntu.com trusty-updates/universe Sources               
Hit http://ppa.launchpad.net saucy/main amd64 Packages                         
Hit http://ec.archive.ubuntu.com trusty-updates/multiverse Sources             
Hit http://ppa.launchpad.net saucy/main i386 Packages                          
Hit http://ec.archive.ubuntu.com trusty-updates/main amd64 Packages            
Hit http://ec.archive.ubuntu.com trusty-updates/restricted amd64 Packages      
Hit http://ec.archive.ubuntu.com trusty-updates/universe amd64 Packages        
Hit http://ec.archive.ubuntu.com trusty-updates/multiverse amd64 Packages      
Hit http://ec.archive.ubuntu.com trusty-updates/main i386 Packages             
Hit http://ec.archive.ubuntu.com trusty-updates/restricted i386 Packages       
Hit http://ec.archive.ubuntu.com trusty-updates/universe i386 Packages         
Hit http://ec.archive.ubuntu.com trusty-updates/multiverse i386 Packages       
Hit http://ec.archive.ubuntu.com trusty-updates/main Translation-en            
Hit http://ec.archive.ubuntu.com trusty-updates/multiverse Translation-en      
Hit http://ec.archive.ubuntu.com trusty-updates/restricted Translation-en      
Hit http://ec.archive.ubuntu.com trusty-updates/universe Translation-en        
Hit http://ec.archive.ubuntu.com trusty-backports/main Sources                 
Hit http://ec.archive.ubuntu.com trusty-backports/restricted Sources           
Hit http://ec.archive.ubuntu.com trusty-backports/universe Sources             
Hit http://ec.archive.ubuntu.com trusty-backports/multiverse Sources           
Hit http://ec.archive.ubuntu.com trusty-backports/main amd64 Packages          
Hit http://ec.archive.ubuntu.com trusty-backports/restricted amd64 Packages    
Hit http://ec.archive.ubuntu.com trusty-backports/universe amd64 Packages      
Hit http://ec.archive.ubuntu.com trusty-backports/multiverse amd64 Packages    
Hit http://ec.archive.ubuntu.com trusty-backports/main i386 Packages           
Hit http://ec.archive.ubuntu.com trusty-backports/restricted i386 Packages     
Hit http://ec.archive.ubuntu.com trusty-backports/universe i386 Packages       
Hit http://ec.archive.ubuntu.com trusty-backports/multiverse i386 Packages     
Hit http://ec.archive.ubuntu.com trusty-backports/main Translation-en          
Hit http://ec.archive.ubuntu.com trusty-backports/multiverse Translation-en    
Hit http://ec.archive.ubuntu.com trusty-backports/restricted Translation-en    
Hit http://ec.archive.ubuntu.com trusty-backports/universe Translation-en      
Ign http://ppa.launchpad.net trusty/main Translation-en_US                     
Ign http://ppa.launchpad.net trusty/main Translation-en                        
Ign http://ppa.launchpad.net trusty/main Translation-en_US                     
Ign http://ppa.launchpad.net trusty/main Translation-en                        
Err http://ppa.launchpad.net trusty/main amd64 Packages                        
  404  Not Found
Err http://ppa.launchpad.net trusty/main i386 Packages                         
  404  Not Found
Ign http://ppa.launchpad.net trusty/main Translation-en_US                     
Ign http://ppa.launchpad.net trusty/main Translation-en                        
Ign http://ppa.launchpad.net saucy/main Translation-en_US                      
Ign http://ppa.launchpad.net saucy/main Translation-en                         
Ign http://ec.archive.ubuntu.com trusty/main Translation-en_US                 
Ign http://ec.archive.ubuntu.com trusty/multiverse Translation-en_US           
Ign http://ec.archive.ubuntu.com trusty/restricted Translation-en_US           
Ign http://ec.archive.ubuntu.com trusty/universe Translation-en_US             
W: Failed to fetch http://download.tuxfamily.org/glxdock/repository/ubuntu/dists/trusty/cairo-dock/binary-amd64/Packages  404  Not Found [IP: 88.191.250.171 80]

W: Failed to fetch http://download.tuxfamily.org/glxdock/repository/ubuntu/dists/trusty/cairo-dock/binary-i386/Packages  404  Not Found [IP: 88.191.250.171 80]

W: Failed to fetch http://ppa.launchpad.net/kalakris/okular/ubuntu/dists/trusty/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/kalakris/okular/ubuntu/dists/trusty/main/binary-i386/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
sebas@PinkFloyd92-:~$ sudo apt-get upgrade 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
sebas@PinkFloyd92-:~$ sudo apt-get -f install 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
sebas@PinkFloyd92-:~$ okular
okular(4788)/kdeui (KIconLoader): Error: standard icon theme "oxygen" not found! 

okular(4788)/kdeui (KIconLoader): Error: standard icon theme "oxygen" not found! 

okular(4788) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(4788) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(4788) KPixmapSequence::frameSize: No frame loaded 
okular(4788) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(4788) KPixmapSequence::frameSize: No frame loaded 
okular(4788) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(4788) KPixmapSequence::frameSize: No frame loaded 
okular(4788) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(4788) KPixmapSequence::frameSize: No frame loaded 
okular(4788) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(4788) KPixmapSequence::frameSize: No frame loaded 
okular(4788) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(4788) KPixmapSequence::frameSize: No frame loaded 
okular(4788): No ksycoca4 database available! 

okular(4788)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "okular/Generator"  not found 
okular(4788)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(4788)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(4788)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(4788)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(4788)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(4788): No ksycoca4 database available! 

okular(4788)/kdecore (trader) mimeTypeSycocaServiceOffers: KMimeTypeTrader: mimeType "application/pdf" not found 
okular(4788): No ksycoca4 database available! 

okular(4788)/kdecore (trader): KMimeTypeTrader: couldn't find service type "okular/Generator" 
Please ensure that the .desktop file for it is installed; then run kbuildsycoca4. 
okular(4788)/okular (app) Okular::Document::openDocument: No plugin for mimetype '"application/pdf"'.
okular(4788): Couldn't start knotify from knotify4.desktop:  "KLauncher could not be reached via D-Bus. Error when calling start_service_by_desktop_path:
The name org.kde.klauncher was not provided by any .service files
" 

okular(4788)/kdeui (KNotification) KNotification::slotReceivedIdError: Error while contacting notify daemon "The name org.kde.knotify was not provided by any .service files" 
2

I had the same problem. Searching the web i found a solution.

Since "A regression in KDE 4.14 prevents these applications from working fine out of the box outside of KDE" you have to install:

  • kdelibs-bin
  • kdelibs5-data
  • kdelibs5-plugins

That will prevent okular to report No ksycoca4 database available! and other KDE related errors.

For the standard icon theme "oxygen" not found! error message, you can istall the oxygen-icon-theme package.

All in one line:

sudo apt install kdelibs-bin kdelibs5-data kdelibs5-plugins oxygen-icon-theme

http://forums.linuxmint.com/viewtopic.php?t=185634&p=972747#p961561 http://forums.linuxmint.com/viewtopic.php?t=185634&p=972747#p972714

0

Your package is probably badly installed, or "broken". It came about perhaps because package dependencies are not complete or in sync with your present system state or with already installed (other) package resources.

To fix a broken package, from the terminal (CTRL+ALT+T), you should:

sudo dpkg --configure -a --force-all
sudo apt-get clean
sudo apt-get update  
sudo apt-get upgrade
sudo apt-get -f install
  • clean clears out the local repository of retrieved package files (files with .deb suffix),
  • update is used to resynchronize the package index files from their sources,
  • upgrade is used to install the newest versions of all packages currently installed on the system from the sources enumerated in /etc/apt/sources.list,
  • 'sudo apt-get -f install' fixes broken packages and gives you a error message for each unmet dependencies. Post the errors here, if any.

Try to run your app again, please post a follow up.
HTH

PS: Apart from all the above, I just saw an excellent post here.It may apply to you. Even it is does not, you will learn quite a bit from @Basharat Sialvi 's "didactics".

0
0

Same problem when trying to run Kexi or Calligra on Linuxmint 17 Cinamon, mintUpdate 4.9.3.2 Kexi would open but close as soone as I tried create the new database (local), Calligra woudl display a warning asking to run some *****.exe program, reinstal or restart PC, did all that with no success.. Both prob. were solved right after I ran this: apt install kdelibs-bin kdelibs5-data kdelibs5-plugins Not an IT guru so thanks for sharing ! :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.