1

The background settings (right click on wallpaper) seem to be locked. I can't change nothing, not even my wallpaper.

Any ideas?

1
1

Does your account have necessary permissions to make changes? You may want to check it by typing in terminal group and it will show what groups you belong to.

Next thing, you can actually change the user background the hard way. There is a profile folder for each user stored in /var/lib/AccountsService/users. For instance, /var/lib/AccountsService/users/sergiy is my account profile. What you can do is to edit that file with the text editor of your choice. I prefer nano. So what I type is this:

sudo nano /var/lib/AccountsService/users/sergiy

It will prompt for your password (considering that you're in sudoer group, of course) and open the file. Locate line starting with [User] and line saying Background . Paste the path to your desired wallpaper after = sign. For instance, here's mine: enter image description here

After you're done editing , reboot.

And one more thing, I've discovered that file org.freedestop.Accounts.service prevents changes to greeter backgrounds, and most likely to user backgrounds. So try editing this file with a text editor to comment out Exec line. Again, for me this is

sudo nano /usr/share/dbus-1/system-services/org.freedesktop.Accounts.service

Change Exec=/usr/lib/accountsservice/accounts-daemon to # Exec=/usr/lib/accountsservice/accounts-daemon

Try this first, and let me know if this helps. I've discovered that after commenting out that line, I was able to change lightdm-gtk greeter background, while previously I could not - it would just override whatever settings I placed into lightdm-gtk-greeter.conf, and show my desktop background instead of the image i wanted.

Note: keep in mind that the first solution I posted, will only work if that Exec line is active, not commented out. Second solution, disables Accounts service

Let me know if this helps. Cheers

9
  • I tried the second option and it didn't work.
    – marlanbar
    Sep 30 '14 at 17:49
  • Okay. What about first one? Try first solution with commented out and not commented Exec line. Sep 30 '14 at 18:14
  • It only changed my loginscreen. When I logged in, the old wallpaper reappeared. I doubled checked the exec line was uncommented.
    – marlanbar
    Sep 30 '14 at 18:23
  • Weird. So i guess something is overriding your Accounts Service settings once you log in , because initially Accounts Service works properly. The big question is what does the override? I know you mentioned you had Cinnamon desktop. What desktop you have now? When you uninstalled did you set your current desktop as default? It's done through sudo dpkg-reconfigure lightdm, where lightdm you could substitute you current desktop name. You'll have menu show up asking to choose default desktop. Once you choose, it updates settings. Reboot. Sep 30 '14 at 18:36
  • No, it didn't work. I entered sudo dpkg-reconfigure lightdm command but it did not show any menus. Another weird thing that might help is that the rotating wallpaper option of cinnamon is still there. Thank you for your effort.
    – marlanbar
    Oct 1 '14 at 3:09
1

I had this problem after I installed cinnamon, had to remove it. Wish I could comment.

3
  • I installed cinnamon some time ago, it must be that. But I think it's not completely uninstalled, because the problem persist.
    – marlanbar
    Sep 28 '14 at 22:39
  • 1
    @daniel: I think this is a valid answer. Sep 28 '14 at 22:50
  • I can't help you there, I just wiped ubuntu and reinstalled. I probably could have removed cinnamon but never figured out how to, or I didn't want to take the time to figure it out. It was basically a fresh install so I just wiped.
    – Daniel
    Sep 29 '14 at 2:45
0

Simply try using gnome-tweak-tool: in "Desktop" tab, toggle "Icons on Desktop" On. Now you can change wallpaper through "Background Location" option, or even using Ubuntu System Settings -> Appreance (that previously was only changing login screen wallpaper). At the end, you can toggle it off, again, if you like.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.