0

My laptop's touchpad doesn't seem to be detected at all on my Gigabyte P35 laptop with Ubuntu 14.04 64-bit. I think it's an Elantech touchpad. Any ideas on how to make it work?

Here are some details:

$ uname -a
Linux cyrille-gigabyte 3.16.0-031600-generic #201408031935 SMP Sun Aug 3 23:36:11 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

I have an external USB mouse connected here:

$ xinput
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Razer Razer Diamondback 3G                id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ HD WebCam                                 id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

idem here

$ cat /proc/bus/input/devices | grep Name
N: Name="Lid Switch"
N: Name="Sleep Button"
N: Name="Power Button"
N: Name="Razer Razer Diamondback 3G"
N: Name="HD WebCam"
N: Name="Video Bus"
N: Name="Video Bus"
N: Name="HDA Intel HDMI HDMI/DP,pcm=3"
N: Name="HDA Intel HDMI HDMI/DP,pcm=7"
N: Name="HDA Intel HDMI HDMI/DP,pcm=8"
N: Name="HDA Intel PCH Mic"
N: Name="HDA Intel PCH Headphone"
N: Name="AT Translated Set 2 keyboard"

Let me know if you need further details on my system.

1

I had the same problem on my new Gigabyte P35 v2 laptop. After a lot of searching, I came across this kernel bug thread:

https://bugzilla.kernel.org/show_bug.cgi?id=81331

After downloading the patch in post 135 in that thread ( https://bugzilla.kernel.org/attachment.cgi?id=145981 ) I applied this to the latest upstream kernel (3.17.0 at the time of this writing), recompiled and booted-- and now the touchpad gets recognized and works fine from a cold boot. (2-finger scrolling, and toggling the touchpad on and off with Fn+F6 works too!)

It's being recognized thus:

I: Bus=0011 Vendor=0002 Product=000e Version=0000
N: Name="ETPS/2 Elantech Touchpad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input6
U: Uniq=
H: Handlers=mouse0 event5
B: PROP=5
B: EV=b
B: KEY=e420 10000 0 0 0 0
B: ABS=661800011000003
| improve this answer | |
  • @Stephen can you expand how to apply the patch? With a link at least? Thank you! – Guillermo Olmedo Mar 4 '15 at 15:33
  • another method that seems to work if your touchpad only works intermittently: power off your laptop for at least 60 seconds (55 won't work), and reboot. see bugzilla.kernel.org/show_bug.cgi?id=81331#c35 – Cyrille Rossant Jun 20 '15 at 9:37
  • Sometimes its the simple of things Tried patch updated kernel to 4.3 and tried about 10 things and in the end it was the Fn+F6 or in my case Fn+F7 doh – damien Nov 7 '15 at 3:42
  • Hi, I'm facing the same issue. Touchpad is not listed in xinput. I've just bought a lenovo ideapad 320E-15IKB D laptop. The touchpad is working fine in windows 10 pro after installing drivers but i tried installing ubuntu 14.04 and 16.04 both and touchpad doesn't work at all. Its elantech as per the drivers i installed in windows. How do i apply this patch. is there a link available? – Akash Raghav Aug 21 '17 at 6:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.