1

i can't run an update from ubuntu 12.04 to 14, during the update process i got souces error. But my network seems to be ok. How can i fix it?

I did the update on my laptop, but i can't do it on my desktop :/

W:Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/dists/trusty/main/binary-armhf/Packages 404 Not Found [IP : 2001:67c:1360:8c01::19 80] (...) 404 Not Found [IP : 2001:67c:1360:8c01::19 80] , W:Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/dists/trusty-proposed/universe/binary-armhf/Packages 404 Not Found [IP : 2001:67c:1360:8c01::19 80] , E:Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

  • What do dpkg --print-architecture and dpkg --print-foreign-architectures say? – s3lph Sep 28 '14 at 17:34
  • it returns "amd64" for the first command and "i386 armhf" for the other. – Ty Kayn Sep 29 '14 at 9:07
0

To do a release update on ubuntu you need to run sudo do-release-upgrade as apt-get update just refreshes the sources for packages and apt-get upgrade just updates all packages to the latest version, but doesn't update to the latest ubuntu release.

  • i tried sudo do-release-upgrade, and the other way with the graphical update manager. The update stopped because of mysterious network errors in both case. – Ty Kayn Sep 29 '14 at 9:09
0

There are no Ubuntu repositories for the armhf architecture. To upgrade, you need to disable the support for this arch during the release upgrade.

  1. Find out, what packages built for armhf you have installed: dpkg -l | grep armhf
  2. Uninstall these packages, if there are any. They cannot be upgraded automatically.
  3. Remove armhf from the multiarch system: sudo dpkg --remove-architecture armhf
  4. Do the upgrade: sudo do-release-upgrade

Optional, if you still need the software you just removed:

  1. Readd the armhf architecture: sudo dpkg --add-architecture armhf
  2. Install the armhf software you removed. (The same way you installed it before.)
  • there is no armhf packages left. finally i succefully the upgrade. but the apt-get update still returns 404 errors – Ty Kayn Sep 30 '14 at 9:33
  • The same errors? The ones according the main/binary-armhf/ tree? – s3lph Sep 30 '14 at 11:09
  • the errors begginig with fr.archive.ubuntu.com/ubuntu/dists/trusty – Ty Kayn Oct 2 '14 at 20:45
  • Did you add the armhf arch after the upgrade? If you don't need it, leav it away. – s3lph Oct 2 '14 at 21:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.