I have been all over the entire askubuntu.com trying to find a solution to my present issue but none has brought any joy, so I gave up and just had to post this.

I have an HP Envy M6 pre-installed with Windows 8 and HP's recovery bloatware, I couldn't survive without Ubuntu and decided to set it up, I got everything set up with a Live CD, created the right partitions and did everything I was supposed to do and then restarted my pc.

As expected, being a UEFI-based pc, I didn't expect to see a grub menu on next startup without some tinkering, so I decided to get EasyBCD, an app that worked fine on my custom built Desktop, I created the Ubuntu entry in the app and got a boot menu after restarting my PC, and tried booting into Ubuntu, then got a nasty error that some Autoneogrub.mbr was corrupted or missing, fine, I came back online to seek help and found out EasyBCD doesn't support new UEFI boards.

Then I ventured into the wild, (I couldn't Boot Into Ubuntu yet), I started reading up on how I could get back grub on a UEFI pc that would boot Windows 8 and Ubuntu fine, then I came across the first answer here. I attempted to boot into Ubuntu from the partion created by choosing to boot from the Ubuntu partition on startup and then perfromed the steps in that answer.

I was able to get grub on startup with the Windows Boot Loader(dev/sda2) entry, but surprisingly I keep getting thrown back into grub, no errors, just grub showing up again, I decided to boot into Ubuntu and reverted back to the state of my /boot/efi/EFI/Microsoft/Boot directory before I performed the former step , and Windows booted again without any Boot Menu's.

I have tried installing rEFInd and boot-repair in Ubuntu to fix this issue but they didn't help, I didn't even get a refind boot manager, neither did boot-repair, so currently the only way I've been able to boot into Ubuntu is by choosing advanced startup in Windows and then selecting to boot from Ubuntu's partitions.

I think HP's EFI might be behind all this, cause I read so many tutorials on dual-booting Ubuntu on a UEFI-based Pc and they were all okay.

  • Possibly related to Ubuntu doesn't provide \EFI\BOOT\BOOTX64.EFI for UEFI systems and askubuntu.com/a/510172/40581 hopfully this helps you fix your problem.
    – LiveWireBT
    Sep 29 '14 at 13:37
  • Regarding your last sentence. I would be more specific and say that the UEFI implementation of this model is at fault, not generally HP. I see more of such issues where consumer orientend models only boot \EFI\BOOT\BOOTX64.EFI and thus only booting Windows and OSes that provide this binary and disregard booting NVRAM entries. I don't know why the market moves into this direction, possibly to reduce complexity, but I recall watching a video of an HP engineer at a Linux conference a few years back talkig about UEFI, stating they were deeply involved with EFI back in IA64 days.
    – LiveWireBT
    Sep 29 '14 at 13:43

When installing any OS on an UEFI based computer and GPT disk installation source - USB/DVD - should be booted the UEFI way.

Nothing more.

Ubuntu GRUB can chainload Windows on BIOS and UEFI. Windows boot manager can chainload GRUB/Ubuntu only on BIOS/MBR.

BootNext utility can boot Ubuntu/Linux directly from Windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.