0

I've succesfully installed lubuntu-desktop on my server just now. I wasn't quite sure what would be installed besides the desktop environment and I found that there's quite a lot installed that I don't need, like games, accessories and browser. Frankly, all I want is a file manager and maybe a way to connect with TeamViewer.

Reasoning: I've got a server with several harddisks that are shared over the network. However, when moving files from one share to the other, they're pulled over the network. Not what I want. I've tried all sorts of things and frankly what I want is to be able to have folderA and folderB side by side and drag/drop without transferring anything over the network. After a bit of research, I've decided that the best option would be to just add a GUI to my server and log in either directly or remote to do this. (Unless someone can find an FTP manager with side-by-side windows showing different folders but over the same connection)

TL;DR: Can I strip down lubuntu-desktop or install just LXDE and a File Manager?

  • Have you looked at Midnight Commander? You can have two locations open in different panels and it works in terminal too – John Kirchner Sep 28 '14 at 12:48
  • Hi John, thanks for your reply. Unfortunately, I can't seem to connect via FTP. I'm running proftpd and have connected with FileZilla so it must be a config issue in MC.. – Diana Sep 28 '14 at 18:38
2

For a bare minimum LXDE-based environment, you can install lxde-core without any recommended additional packages, instead of lubuntu-desktop

sudo apt-get install --no-install-recommends lxde-common lxde-core

This will give you the basic openbox window manager, plus the lxsession session manager and pcmanfm file manager. IIRC it does not install a display manager, so your server will continue to boot to a CLI and you will need to use startx to get the GUI environment. You may need to create a minimal .xsession file in your home directory e.g.

echo 'lxsession -e LXDE -s LXDE' > $HOME/.xsession
  • Hi steeldriver, thanks for replying. I'm following your advice right now. Currently also installing package xinit, for startx – Diana Sep 28 '14 at 18:57
  • Hm, after startx, the terminal shows "waiting for xserver to begin accepting connections", after which it repeatedly outputs "no protocol specified". I've found some topics online regarding this, will investigate and report back here later this week. Hopefully I can confirm your answer then :) Thanks! – Diana Sep 28 '14 at 19:13
  • I had to remove all .Xauthority* files in my home directory (ubuntuforums.org/showthread.php?t=1835833), after that it worked! Thanks :) – Diana Oct 1 '14 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.