19

I am trying to use notify-send, but it doesn't display.

I am reasonably sure I have the correct packages installed, but I am not expert in configuring the notification settings.

I know I have some sort of notification package working - I get notifications from Pidgin (sporadically).

What is the correct configuration for notify-send to operate correctly?

  • I have libnotify-bin installed

  • I have the notification-daemon installed

6 Answers 6

16
+50

There are no special configuration files as far as I know so I would try and reinstall the package

sudo apt-get --reinstall install libnotify-bin notify-osd
4
  • You don't have to reinstall the two packages separately, but can do so with a single command: sudo apt-get --reinstall install libnotify-bin notify-osd Jul 5, 2012 at 12:39
  • 2
    Under Debian Wheezy I need also start notification daemon like /usr/lib/notify-osd/notify-osd
    – gavenkoa
    Aug 8, 2012 at 19:45
  • 1
    I also discover notification-daemon under Debian which have nicer look.
    – gavenkoa
    Aug 8, 2012 at 19:50
  • For arch users: pacman -Rnsdd libnotify && pacman -Sy libnotify Nov 25, 2016 at 16:40
4

In my case, the notification was not displayed because I had netbeans in full screen mode in the background.

For some weird reason, the message was getting hidden.

2
  • Strange. Had the same problem with a terminal running full screen trying this. Making it a window magically fixes it.
    – jaxrtech
    Apr 10, 2014 at 23:19
  • I had the same with PHPStorm, thanks for commenting as it was confusing me as to why it wasn't working.
    – Chris0
    Aug 13, 2017 at 18:26
3

In my case, it only works with a zero time limit (-t 0) or with critical urgency (-u critical).

notify-send -t 0 "Nagging you."
notify-send -u critical "It's critical"
1
  • If you have xfce4-notifyd installed and it is happening to you, then open xfce4-notifyd-config and go to applications and let allowed the notify-send entry. Aug 26, 2021 at 21:16
2

In my case is because of I accidentally disable Notification Banners settings.

enter image description here

Note that this answer might not relevant to OP case which claims that Pidgin is working. But it should help someone based on the question title.

1

You need to install libnotify-bin to be able to use the "notify-send" command.

2
  • It's been installed. Jul 13, 2011 at 20:58
  • @Paul: then it should work... I am sure that's the required package to be able to use notify-send, unless something is wrong with libnotify on your system. Jul 14, 2011 at 20:56
0

little hint:

From: [https://bugs.launchpad.net/ubuntu/+source/update-notifier/+bug/300463]

As described in http://forum.lxde.org/viewtopic.php?f=8&t=114&p=287 the update-notifier daemon is not run automatically on other desktops who support it, so I don't get automatic updates as specified in the configuration unless I manually run the update-manager (which works alright).

In:

   /etc/xdg/autostart/update-notifier.desktop

There is a line inside this file read like this:

   OnlyShowIn=GNOME;XFCE;

This line should be changed to: NotShowIn=KDE; Or other unsupported desktops.

I'm using Xubuntu 8.10 and the LXDE desktop environment (that's how I found out)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.