-1

I wanted to try ubuntu on my laptop without installing it, so I thought that installing the “ubuntu CD boot helper” would be useful; I installed it on windows 8 and, after that, everytime I turned the computer on, I got a *blue screen asking me to choose ubuntu or windows; with the ubuntu live CD inserted, I picked the option 'ubuntu' on the blue screen, but the CD never booted using this method, I just got an *error message. I didn't try to get rid of this blue screen and the error coz I thought it would be replaced by GRUB2 after the instalation of Ubuntu.

I then created a Ubuntu live USB (14.04) and installed ubuntu following all the steps on this tutorial (http://itsfoss.com/install-ubuntu-1404-dual-boot-mode-windows-8-81-uefi/), but nothing worked; Grub didnt appear, I then was provided with a *black screen (the windows boot manager) that asked me to choose between ubuntu and windows, and got the same error message after picking the ubuntu option (btw this windows boot manager appeared everytime i turned the computer on). Reading the comments on that tutorial, I found out that, during the instalation of ubuntu, I picked the wrong device for the boot loader; making some research I found out that, if there is an EFI partition, the boot loader have to be placed there.

So I used the windows disk management to erase the partitions created for ubuntu, left the space unallocated and installed ubuntu all over again, this time placing the boot loader in the EFI partition. Now Grub works well, I can boot on both operating systems when I need them. The problem is that, unlike I thought, the Grub didnt replace the windows 8 boot manager, they now coexist; in the Grub options, there are the following:

-Ubuntu

-Advanced options for ubuntu

-system setup

-Windows boot manager

Whenever I want to use windows I have to choose the option "windows boot manager", it then shows the black screen with options for Ubuntu and Windows, and only after picking this option I can access windows. So I want to know how can I get rid of that annoying windows boot manager (if its any possible at all?!) or add an entry on Grub so I can boot on Windows directly when necessary (replace "windows boot manager" option for a "windows" option).

*my screens mentioned here, with equivalents in english (I cant post pictures or more than 2 links since I dont have 10 points reputation): https://drive.google.com/folderview?id=0B0CB6GipDaHZMXlMN0F2SEpGU3c&usp=sharing

  • Did you install Ubuntu twice (once using Wubi, perhaps)? – muru Sep 28 '14 at 5:29
  • I think Wubi doesnt work on a new Windows 8 machine.. But I did install twice, and before that I wanted to try ubuntu without installing it, but I didnt know how to boot from a CD, so I installed the "Ubuntu CD boot helper" (which didnt help anyway). – Annabel Sep 29 '14 at 0:53
  • How does this second screen/menu look like? Could you please post a screenshot/photo (edit your question)? How did you reinstall the boot loader to the EFI partition? – LiveWireBT Sep 29 '14 at 13:24
0

You're getting wrong information here. You cannot "get rid" of the Windows boot loader, it's part of Windows. Normally, if there is only one Windows installation, you don't get a menu or any options, it just boots into Windows. Somehow, that "boot helper" you installed, wrote an additional menu entry to the WINDOWS boot loader. When you installed Ubuntu, and grub, that Windows boot loader simply became an option in the grub menu. You can't fix it from Ubuntu or grub, it needs to be fixed from Windows, with BootRec or such. Then you'll probably have to rebuild the grub menu, or just reinstall Linux once you have Windows booting the way you want. The correct way to set up a multiboot system with Linux is to always install Windows FIRST, then Linux/grub. Othewise, Windows simply overwrites the MBR and your grub menu disappears. Windows is not designed to allow other boot managers, nor will it automatically add non-Windows operating systems to it's own menu...though this can be done manually.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.