10

Using the command line, I want to mute the sound effects in Ubuntu 14.04.

The GUI way of doing so is going to System Settings (unity-control-center), then going to the Sound Effects tab: enter image description here

The answer to this question outlines a way to do so using gconf (sudo su gdm -c "gconftool-2 --set /desktop/gnome/sound/event_sounds --type bool false"), but that no longer works in newer versions of Ubuntu.

I also looked for a clue at the output of pacmd info, but couldn't find anything useful either.

There is what seems to be a relevent setting that can be changed in dconf (org/gnome/desktop/sound/event-sounds), but it is set to false and changes nothing. There are some Ubuntu settings, especially for Unity, that don't have visible dconf settings. Still, they can be seen when changed with a GUI while running dconf watch /. But it shows nothing when muting/un-muting that setting.

I know I could just remove all the sound effects, but there must be a proper way of doing this...

  • Just the alerts, not all sounds, correct? – Seth Oct 1 '14 at 19:22
  • @Seth Yes, just the alert sounds that turn off when you check the box to mute in the picture. – Aibara Oct 1 '14 at 19:30
  • I'm not sure if this is a bug: dconf write /org/gnome/desktop/sound/event-sounds false disabled events sounds. It seems to me as that gsetting key is not binded to Mute (variable). If you want to use CLI, keep Mute unchecked then use event-sounds key. to use GUI keep event-sounds true and use Mute check box. – user.dz Oct 4 '14 at 14:16
  • @Sneetsher But using dconf write (or gsettings set) to change event-sounds does nothing, whether or not the Mute button in the GUI is checked. – Aibara Oct 6 '14 at 17:58
  • 1
    @Sneetsher - No; I don't even have a gdm.d directory in /etc/dconf/db, only ibus.d, and nothing involving locks. – Aibara Oct 7 '14 at 19:52
4
+100

It's a bug and you need to report it. I test that on Ubuntu-Tweak tool and capturing by dconf watch / it's capturing correctly but I see no changes from default sound settings, it's still don't change to Mute.

see the screen shot: if I turn off it:

enter image description here

And if I turn on:

enter image description here

And as you see the default path is correct(org/gnome/desktop/sound/event-sounds), but the changes not take any effect on turning off/mute the "Sound Effects" and in both state I have no changes. I also tested it by rebooting system but no luck.

So it's a bug.

  • 1
    My guess is that you are probably right, since that setting used to work fine. But in this case, couldn't that just mean that Ubuntu Tweak is using the wrong setting, one just for GNOME and not Unity? – Aibara Oct 2 '14 at 18:04
  • In my desktop changing the settings in the sound effects tabs do work, but dconf watch / doesn't output anything. So I suppose it's setting something different... – Rmano Oct 7 '14 at 17:19
  • I did file this bug: bugs.launchpad.net/ubuntu/+source/unity-control-center/+bug/… – Aibara Oct 8 '14 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.