I've always had issues with compatibility between my Android phone and Ubuntu, but now it's gotten to the point that I can't do anything with it over USB. It's always been that when I plug in my device, an error message appear:

"Unable to mount Android phone "Unable to open MTP device '[usb:001,035]'"

Regardless, I was able to manage my files as long as the phone was unlocked when I plugged it in. However, I now seem to get a new error message (or at least one that I don't recall getting before), which reads:

Unhandled error message:  No such interface 'org.gtk.vfs.Mount' on object at path/org/gtk/vfs/mount/1

I'm not sure if this is the root of my problem. I can view all of the files on my Android device, but when I try to do anything like creating/deleting files, I receive a message saying something like:

Error while creating directory Untitled Folder.
There was an error creating the directory in mtp://[usb001,037]/Internal%20storage.

Under "Show more details", I receive the error:

libmtp error:  Could not send object info.

I can do everything I need to over FTP, but it ridiculously slow for large files. Any help getting my Android and PC to talk to each other is greatly appreciated.

  • Make sure the device is connected in Mass storage mode (MSC) and not in Media transfer mode (MTP). – user457885 Jun 14 '16 at 3:50

The conflict is between Banshee and the file manager (Nautilus), both are trying to access the device. So if you want to copy the playlist to the device, you must deactivate all the extensions that access your device, in Banshee's Preferences.

Then open your device's music folder in Nautilus, and copy/paste your playlists from Banshee to the Nautilus' window.

This worked for me with Ubuntu 14.04 + Jolla phone with Sailfish OS.

  • I don't use Banshee but the problem still persists – abhishah901 Dec 10 '15 at 10:09
  • 1
    Just want to note that this solved my problem as well -- make sure Banshee is not running in the background – mb7744 Apr 13 '16 at 15:06

Try this

sudo apt-get install mtpfs

Then reconnect phone. This works for me. Samsung Note 2 Android 4.4.2

  • I have same problem as OP, and installing mtpfs did not solve the issue. I still get the same error when connecting my phone via USB, which worked perfectly fine in 12.04, 12.10, 13.04, and 13.10. Now with 14.04 upgrade, I cant seem to connect my phone at all. – Todd Oct 13 '14 at 19:11
  • 1
    im passed the 5 min comment edit window... but apparently my phone (Samsung S5) will connect if i leave the usb plugged in for about 10 mins or so. I was browsing the web for bug reports/solutions on this, then all the sudden was able to click into the phone via nautilus and find my SD card and data i wanted... – Todd Oct 13 '14 at 19:31
  • 1
    also wanted to note - i have a second 14.04 machine that had this same problem, and simply installing 'mtpfs' fixed this, though again it took about 10 minutes after the install for it to start working. i also noticed that if i turned banshee media player on, i couldnt access data in my phone, and turning banshee off immediately restored access to the SD card. – Todd Oct 13 '14 at 23:54
  • From insane comments and "nothing will work, trust me Linux doesn't work that way" advices. I salute you :) 1 seconds job solved my 20 day problem. – user3041058 Jul 11 '15 at 17:32
  • 1
    Doesnt work even after I rebooted my system... I'm using Galaxy Grand – abhishah901 Dec 10 '15 at 10:07

I had the same problem, but simply closing Banshee solved it. Make sure you don't have any other programs currently accessing the device.

  • I don't use Banshee but the problem still persists – abhishah901 Dec 10 '15 at 10:08

You could also use:

adb push /path/to/file /path/to/phonestorage 

you need the ADB drivers installed on your computer. You also have to enable USB debugging in developer options on your device.

To enable developer options, go to: Settings>About Phone> Tap Build-number 7 times. (Enabled)

Then go back to settings, you'll find developer options right above About Phone. In here you'll find USB debugging.

When you enable this and connect your device to your computer, it will ask you to give your computer permission with the RSA key (tick the box before accepting it to let the permission stick).

This is for me even quicker then just copying files over like we normally do.

  • Same problem over adb on Samsung S5 running cyanogenmod 13.1 – Tony Martin Dec 4 '16 at 19:41

I had the following error:

libmtp error:  Could not send object info.

error message due to a : in the file name. I renamed the file, and the problem was solved.

  • Similar issue due to either an emoji or an ampersand in the file name (or possibly some other weird zero-width character or something.) – MalcolmOcean Jan 23 '19 at 23:36

I had a similar problem, which was not fixed by the various answer given above. The directory would mount and I could see files, but after a few seconds it would not work anymore. The quick fix solution was: I noticed that the connection breaks everytime the phone goes into "screen lock" mode. So I started swiping the phone screen continuously with one hand while I copied files with the other hand, and that actually worked. I don't know the "correct" fix for this though.

  • If the screen lock was the problem you can disable it or set its timer to a much longer period in the phone configuration. – David Foerster Dec 23 '16 at 11:29

Same problem. Thousands of popups and file explorer windows would keep coming as soon as I connect my phone. I solved it by choosing "Camera (PTP)" in my phone instead of "Media device (MTP)" by clicking the usb notification.

enter image description here

  • In this mode, I can't even see anything but photos. – tomasz May 21 '19 at 17:03

I had encounter the same problem after a period when the files transfer worked well. But, after some tries, I've got the cause; that the device's file system showed by the mtp protocol on the computer is not correctly synced by the real one: it not show a file/dir that is physically exist on the device, and a creation/renaming of the same entity on the file system occur this error. Solution: keep manually (explorer app) the file system to the same state of the presented one.

I don't know the cause of this mistake.

I hope that can be useful for someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.