1

I was unable to boot Ubuntu after setting my BIOS to default. I tried Boot-repair and tried a "recommended repair". After a while it asks me to insert the following in Terminal:

sudo chroot "/mnt/boot-sav/sda2" dpkg --configure -a

sudo chroot "/mnt/boot-sav/sda2" apt-get install -fy

sudo chroot "/mnt/boot-sav/sda2" apt-get purge -y --force-yes grub* shim-signed linux-signed*

Than I get an error saying: Grub still present, try again. Boot-info gives the following output:

http://paste.ubuntu.com/8429040

Does this output look "healthy" to you, or do I miss my boot-partition? Does anyone know how I can make my Ubuntu bootable again?

  • How about sudo update-grub – user271219 Sep 28 '14 at 12:30
1

You do not have grub installed in your MBR.

You can simply re-install grub from a live cd.

The process is a bit complicated, involves mounting a few partitions and installing grub.

Give this a try and keep us posted on your results.

  • With UEFI you do not install grub to the gpt protective MBR unless you want to boot in Legacy/BIOS boot mode. You should be able to boot in UEFI boot mode. Unless you want the signed versions for secure boot you should not need to install those. What vendor/model system? Some vendors modify UEFI to only boot Windows and we have to create work arounds like rename grub to look like Windows or copy grub into the hard drive boot entry (which you do not yet have). askubuntu.com/questions/486752/… – oldfred Sep 27 '14 at 23:30
  • @oldfred, he said BIOS didn't he? – trve.fa7ad Sep 27 '14 at 23:36
  • He may have said BIOS and many still call UEFI BIOS as it also has a BIOS boot mode called CSM. But Boot Summary shows efi partition and efi boot files for UEFI boot. Many users are not sure of configuration and we have to review things like Boot-Repair's summary report to really know how system is configured. – oldfred Sep 28 '14 at 3:56
  • @oldfred, Zeus77, thank you for your reply. I have an Acer Aspire X3995, which ran Ubuntu fine until loading the default settings of BIOS to default. I will have a crack at it, and let you know! – Rob Lamb Sep 28 '14 at 17:35
  • If you reset UEFI/BIOS to defaults that reverses all the changes you may have made. I found when I updated my BIOS it reset everything back to defaults and all sorts of things stopped working. I had to take photos of each BIOS screen so I could remember settings. – oldfred Sep 28 '14 at 23:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.