6

I'm trying to add a vpn connection through the openconnect and using the gui. Even though it says that I am connected, I can't access any of the websites on the network I'm trying to connect to.

However, if I run this command in the terminal, I am able to access the websites.

sudo openconnect blah.google.blah

So it's probably the sudo access? How can I add that to the gui?

  • Same problem, Kubuntu 15.04 – Scott Beeson Sep 17 '15 at 14:30
  • Same problem, Ubuntu 18.04 – mmaceachran Sep 26 '18 at 15:06
2

Enable the proposed repositories

https://wiki.ubuntu.com/Testing/EnableProposed

then you can install

sudo apt-get install network-manager-openconnect network-manager-openconnect-gnome

This will allow you to configure them via the NetworkManager GUI.

  • (I'm on Ubuntu 14.04) - I enabled that repository, then ran the command you suggested but I get "0 upgraded, 0 newly installed". I then tried sudo apt-get install network-manager-openconnect/xenial-proposed network-manager-openconnect-gnome/xenial-proposed but got E: Release 'xenial-proposed' for 'network-manager-openconnect' was not found E: Release 'xenial-proposed' for 'network-manager-openconnect-gnome' was not found – David Doria Sep 27 '16 at 0:48
  • 14.04 is not xenial its trusty , you need to edit your apt configuration – Amias Sep 27 '16 at 9:23
  • Oops, you're right, but it still didn't work: sudo apt-get install network-manager-openconnect/trusty-proposed network-manager-openconnect-gnome/trusty-proposed E: Release 'trusty-proposed' for 'network-manager-openconnect' was not found E: Release 'trusty-proposed' for 'network-manager-openconnect-gnome' was not found – David Doria Sep 27 '16 at 11:44
  • Note that this is the line in my sources.list deb http://us.archive.ubuntu.com/ubuntu/ trusty-proposed universe multiverse restricted main – David Doria Sep 27 '16 at 11:45
  • just to check you have done and apt-get update since adding the new repos haven't you ? – Amias Sep 27 '16 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.