0

I have been trying to install gnome3 to my ubuntu. And a had a partial success. At some point of installation, I came to an error, which I don't have any luck of solving, and I have searched for hours. The installation of gnome3 is now not that much of an issue, but of solving a dependency problem.

The problem is this: Every time I run an e.g. sudo apt-get install -f I get an error:

The following packages have unmet dependencies: libgtksourceview-3.0-1 : Depends: libgtksourceview-3.0-common (>= 3.10.2-0ubuntu1~saucy1) but 3.8.2-0ubuntu1 is installed E: Unmet dependencies. Try using -f.

when I run a apt-cache policy libgtk-3.0 I get:

libgtk-3-0-dbg:   Installed: (none)   Candidate:
3.10.7-0ubuntu1~saucy1   Version table:
     3.10.7-0ubuntu1~saucy1 0
        500 http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu/ saucy/main amd64 Packages
     3.10.6-0ubuntu2~saucy1 0
        500 http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu/ saucy/main amd64 Packages
     3.8.4-0ubuntu3 0
        500 http://rs.archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages libgtk-3-0:   Installed: 3.10.7-0ubuntu1~saucy1   Candidate:
3.10.7-0ubuntu1~saucy1   Version table:  *** 3.10.7-0ubuntu1~saucy1 0
        500 http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu/ saucy/main amd64 Packages
        100 /var/lib/dpkg/status
     3.10.6-0ubuntu2~saucy1 0
        500 http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu/ saucy/main amd64 Packages
     3.8.4-0ubuntu3 0
        500 http://rs.archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages

I have tried removing libgtksourceview-3.0-common so I could install a new version, but I also get:

> sudo apt-get remove libgtksourceview-3.0-common

The following packages have unmet dependencies:
 libgtksourceview-3.0-1 : Depends: libgtksourceview-3.0-common (>= 3.10.2-0ubuntu1~saucy1) but it is not going to be installed

Does anybody have an idea how can I fix this dependency issue? This has happened on latest ubuntu 14.04 and also on earlier versions , like 13.10

0

You have the GNOME3 PPAs (presumably added while you were using 13.10, and so still using the 13.10 tag). Update the PPA entries to use trusty instead of saucy, or remove the PPAs altogether:

sudo sed -i 's/saucy/trusty/g' /etc/apt/sources.list.d/*.list
sudo apt-get update

Note that if you do choose to remove the PPA, you will have to use ppa-purge, considering the extent of the effect the GNOME PPAs have.

6
  • Yes, it does make sense, but just wondering, is it possible to remove the 3.8.2-0ubuntu1 as it seems that that is causing the problem as I have it still installed? – Aleks Sep 27 '14 at 19:03
  • @Aleks The second error was about libgtksourceview-3.0-1. Try removing both together: sudo apt-get remove libgtksourceview-3.0-common libgtksourceview-3.0-1. – muru Sep 27 '14 at 19:04
  • Hmm, have tried that earlier, but now again with your command and I am getting an error gedit : Depends: libgtksourceview-3.0-1 (>= 3.10) but it is not going to be installed :/ – Aleks Sep 27 '14 at 19:07
  • @Aleks looks too ingrained to me. You can try downloading the newer versions using the Ubuntu packages index and installing them manually using dpkg -i. – muru Sep 27 '14 at 19:08
  • 1
    I am going to accept this answer, even though the above commands didn't solve my problem, but it directed me to where the problem was and what was the problem - in PPA sources. Thanks – Aleks Jan 16 '15 at 8:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.