I have a System76 Gazelle, gapz8, running Ubuntu 14.04. My wifi keeps dropping out at random intervals. I have a new router, so I don't believe that's the issue, but I am in an apartment building, so the signals are probably crowded. My computer still registers the wifi as connected, but stops sending and receiving data. I've found that disconnecting from the wifi and reconnecting fixes the problem, but it can happen again within minutes. Does anyone understand the problem or how to fix it? I'm happy to provide more information if that will clarify the issue, just tell me what.

As requested below, the results from the "wireless script""

########## wireless info START ##########

Report from: 28 Sep 2014 23:17 EDT -0400

Booted last: 28 Sep 2014 20:28 EDT -0400

Script from: 20 Sep 2014 23:04 UTC +0000

##### release ###########################

Distributor ID: Ubuntu
Description:    Ubuntu 14.04.1 LTS
Release:    14.04
Codename:   trusty

##### kernel ############################

Linux 3.13.0-36-generic #63-Ubuntu SMP Wed Sep 3 21:30:07 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, quiet, splash, acpi_os_name=Linux, acpi_osi=, vt.handoff=7

##### desktop ###########################

Ubuntu

##### lspci #############################

02:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 2230 [8086:0887] (rev c4)
    Subsystem: Intel Corporation Centrino Wireless-N 2230 BGN [8086:4062]
    Kernel driver in use: iwlwifi

03:00.2 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0a)
    Subsystem: CLEVO/KAPOK Computer Device [1558:2706]
    Kernel driver in use: r8169

##### lsusb #############################

Bus 002 Device 003: ID 5986:0401 Acer, Inc 
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 045e:00e1 Microsoft Corp. Wireless Laser Mouse 6000 Reciever
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

##### PCMCIA card info ##################

##### rfkill ############################

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

##### lsmod #############################

iwldvm                232285  0 
mac80211              630653  1 iwldvm
iwlwifi               169932  1 iwldvm
cfg80211              484040  3 iwlwifi,mac80211,iwldvm
wmi                    19177  0 

##### interfaces ########################

auto lo
iface lo inet loopback

##### ifconfig ##########################

eth0      Link encap:Ethernet  HWaddr   
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr   
          inet addr:192.168.1.5  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::626c:66ff:fe30:1786/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:132928 errors:0 dropped:0 overruns:0 frame:0
          TX packets:81169 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:167705002 (167.7 MB)  TX bytes:10766737 (10.7 MB)

##### iwconfig ##########################

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"Router 2: Electric Boogaloo"  
          Mode:Managed  Frequency:2.417 GHz  Access Point:    
          Bit Rate=65 Mb/s   Tx-Power=16 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=63/70  Signal level=-47 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:67   Missed beacon:0

##### route #############################

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     9      0        0 wlan0

##### resolv.conf #######################

nameserver 127.0.1.1

##### nm-tool ###########################

NetworkManager Tool

State: connected (global)

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             unavailable
  Default:           no
  HW Address:        

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off

- Device: wlan0  [Router 2: Electric Boogaloo] ---------------------------------
  Type:              802.11 WiFi
  Driver:            iwlwifi
  State:             connected
  Default:           yes
  HW Address:        

  Capabilities:
    Speed:           115 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    Lucille:         Infra, , Freq 2427 MHz, Rate 54 Mb/s, Strength 75 WPA WPA2
    DG1670A82:       Infra, , Freq 2437 MHz, Rate 54 Mb/s, Strength 62 WPA2
    Mcchacko-2G:     Infra, , Freq 2412 MHz, Rate 54 Mb/s, Strength 52 WPA2
    DIRECT-roku-900: Infra, , Freq 2437 MHz, Rate 54 Mb/s, Strength 50 WPA2
    B4R87:           Infra, , Freq 2437 MHz, Rate 54 Mb/s, Strength 44 WPA2
    NETGEAR65:       Infra, , Freq 2437 MHz, Rate 54 Mb/s, Strength 42 WPA2
    cheeky:          Infra, , Freq 2462 MHz, Rate 54 Mb/s, Strength 27 WPA2
    DG1670A22:       Infra, , Freq 2412 MHz, Rate 54 Mb/s, Strength 25 WPA2
    *Router 2: Electric Boogaloo: Infra, , Freq 2417 MHz, Rate 54 Mb/s, Strength 77 WPA2
    Wellfords:       Infra, , Freq 2412 MHz, Rate 54 Mb/s, Strength 57 WPA WPA2
    RubyWillow:      Infra, , Freq 2437 MHz, Rate 54 Mb/s, Strength 40 WPA WPA2
    Waffle House:    Infra, , Freq 2412 MHz, Rate 54 Mb/s, Strength 27 WPA WPA2
    Linksys e3200:   Infra, , Freq 2412 MHz, Rate 54 Mb/s, Strength 27 WPA WPA2
    RubyWillow-guest:Infra, , Freq 2437 MHz, Rate 54 Mb/s, Strength 45
    TG1672G12:       Infra, , Freq 2427 MHz, Rate 54 Mb/s, Strength 34 WPA2
    55B2Q:           Infra, , Freq 2462 MHz, Rate 54 Mb/s, Strength 34 WPA2
    luna:            Infra, , Freq 2437 MHz, Rate 54 Mb/s, Strength 30 WPA WPA2
    Linksys e3200-guest: Infra, , Freq 2412 MHz, Rate 54 Mb/s, Strength 27

  IPv4 Settings:
    Address:         192.168.1.5
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1

    DNS:             192.168.1.1

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true

##### NetworkManager.conf ###############

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

##### NetworkManager profiles ###########

[[/etc/NetworkManager/system-connections/Apple Network 5df1bd]] (600 root)
[connection] id=Apple Network 5df1bd | type=802-11-wireless
[802-11-wireless] ssid=Apple Network 5df1bd | mac-address=
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/200W102nd3E]] (600 root)
[connection] id=200W102nd3E | type=802-11-wireless
[802-11-wireless] ssid=200W102nd3E | mac-address=
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/NETGEAR49]] (600 root)
[connection] id=NETGEAR49 | type=802-11-wireless
[802-11-wireless] ssid=NETGEAR49 | mac-address=
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/NYU-ROAM3]] (600 root)
[connection] id=NYU-ROAM3 | type=802-11-wireless
[802-11-wireless] ssid=NYU-ROAM3 | mac-address=
[ipv6] method=auto
[ipv4] method=auto

[[/etc/NetworkManager/system-connections/Router 2: Electric Boogaloo]] (600 root)
[connection] id=Router 2: Electric Boogaloo | type=802-11-wireless
[802-11-wireless] ssid=Router 2: Electric Boogaloo | mac-address=
[ipv4] method=auto
[ipv6] method=auto

##### iw reg get ########################

Region: America/New_York (based on set time zone)

country 00:
    (2402 - 2472 @ 40), (3, 20)
    (2457 - 2482 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
    (2474 - 2494 @ 20), (3, 20), NO-OFDM, PASSIVE-SCAN, NO-IBSS
    (5170 - 5250 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
    (5735 - 5835 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS

##### iwlist channels ###################

eth0      no frequency information.

lo        no frequency information.

wlan0     13 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz
          Current Frequency:2.417 GHz (Channel 2)

##### iwlist scan #######################

Channel occupancy:

      2   APs on   Frequency:2.412 GHz (Channel 1)
      1   APs on   Frequency:2.417 GHz (Channel 2)
      1   APs on   Frequency:2.427 GHz (Channel 4)
      7   APs on   Frequency:2.437 GHz (Channel 6)
      1   APs on   Frequency:2.457 GHz (Channel 10)
      1   APs on   Frequency:2.462 GHz (Channel 11)

eth0      Interface doesn't support scanning.

lo        Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 
                    Channel:2
                    Frequency:2.417 GHz (Channel 2)
                    Quality=60/70  Signal level=-50 dBm  
                    Encryption key:on
                    ESSID:"Router 2: Electric Boogaloo"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000000226ee9d93
                    Extra: Last beacon: 44ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
          Cell 02 - Address: 
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=44/70  Signal level=-66 dBm  
                    Encryption key:on
                    ESSID:"Mcchacko-2G"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=00000051d26350a2
                    Extra: Last beacon: 44ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
          Cell 03 - Address: 
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=48/70  Signal level=-62 dBm  
                    Encryption key:on
                    ESSID:"Wellfords"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=00000000bfdb08ba
                    Extra: Last beacon: 44ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
          Cell 04 - Address: 
                    Channel:4
                    Frequency:2.427 GHz (Channel 4)
                    Quality=58/70  Signal level=-52 dBm  
                    Encryption key:on
                    ESSID:"Lucille"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000001d3ad33a1d
                    Extra: Last beacon: 44ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
          Cell 05 - Address: 
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=44/70  Signal level=-66 dBm  
                    Encryption key:on
                    ESSID:"RubyWillow"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=000000d59bbc1370
                    Extra: Last beacon: 44ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
          Cell 06 - Address: 
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=50/70  Signal level=-60 dBm  
                    Encryption key:on
                    ESSID:"NETGEAR65"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000002fda7d406be
                    Extra: Last beacon: 44ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
          Cell 07 - Address: 
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=32/70  Signal level=-78 dBm  
                    Encryption key:on
                    ESSID:"luna"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000000007386e99
                    Extra: Last beacon: 692ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
          Cell 08 - Address: 
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=53/70  Signal level=-57 dBm  
                    Encryption key:on
                    ESSID:"DG1670A82"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=000002913cbce2ae
                    Extra: Last beacon: 44ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
          Cell 09 - Address: 
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=41/70  Signal level=-69 dBm  
                    Encryption key:on
                    ESSID:"DIRECT-roku-900"
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000001bb4835fa76
                    Extra: Last beacon: 44ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
          Cell 10 - Address: 
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=44/70  Signal level=-66 dBm  
                    Encryption key:off
                    ESSID:"RubyWillow-guest"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=000000d59bbc2e70
                    Extra: Last beacon: 44ms ago
          Cell 11 - Address: 
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=36/70  Signal level=-74 dBm  
                    Encryption key:on
                    ESSID:"B4R87"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=00000077da1f65f7
                    Extra: Last beacon: 44ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
          Cell 12 - Address: 
                    Channel:10
                    Frequency:2.457 GHz (Channel 10)
                    Quality=24/70  Signal level=-86 dBm  
                    Encryption key:on
                    ESSID:"Trust but Verify 2"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000002b08ecdcda
                    Extra: Last beacon: 480ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
          Cell 13 - Address: 
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=30/70  Signal level=-80 dBm  
                    Encryption key:on
                    ESSID:"cheeky"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000001c711ca046e
                    Extra: Last beacon: 44ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK

##### module infos ######################

[iwldvm]
filename:       /lib/modules/3.13.0-36-generic/kernel/drivers/net/wireless/iwlwifi/dvm/iwldvm.ko
license:        GPL
author:         Copyright(c) 2003-2013 Intel Corporation 
version:        in-tree:
description:    Intel(R) Wireless WiFi Link AGN driver for Linux
srcversion:     CC4D1BA11C1EF73A6ABDE53
depends:        iwlwifi,mac80211,cfg80211
intree:         Y
vermagic:       3.13.0-36-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        38:F3:B6:C6:3A:85:AF:FD:FB:BE:0E:53:33:9D:F8:E0:C6:B6:C9:D5
sig_hashalgo:   sha512

[mac80211]
filename:       /lib/modules/3.13.0-36-generic/kernel/net/mac80211/mac80211.ko
license:        GPL
description:    IEEE 802.11 subsystem
srcversion:     B822641624778B987844F6F
depends:        cfg80211
intree:         Y
vermagic:       3.13.0-36-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        38:F3:B6:C6:3A:85:AF:FD:FB:BE:0E:53:33:9D:F8:E0:C6:B6:C9:D5
sig_hashalgo:   sha512
parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[iwlwifi]
filename:       /lib/modules/3.13.0-36-generic/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko
license:        GPL
author:         Copyright(c) 2003-2013 Intel Corporation 
version:        in-tree:
description:    Intel(R) Wireless WiFi driver for Linux
firmware:       iwlwifi-100-5.ucode
firmware:       iwlwifi-1000-5.ucode
firmware:       iwlwifi-135-6.ucode
firmware:       iwlwifi-105-6.ucode
firmware:       iwlwifi-2030-6.ucode
firmware:       iwlwifi-2000-6.ucode
firmware:       iwlwifi-5150-2.ucode
firmware:       iwlwifi-5000-5.ucode
firmware:       iwlwifi-6000g2b-6.ucode
firmware:       iwlwifi-6000g2a-5.ucode
firmware:       iwlwifi-6050-5.ucode
firmware:       iwlwifi-6000-4.ucode
firmware:       iwlwifi-7265-7.ucode
firmware:       iwlwifi-3160-7.ucode
firmware:       iwlwifi-7260-7.ucode
srcversion:     C2D0F3DFCA289585C100E36
depends:        cfg80211
intree:         Y
vermagic:       3.13.0-36-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        38:F3:B6:C6:3A:85:AF:FD:FB:BE:0E:53:33:9D:F8:E0:C6:B6:C9:D5
sig_hashalgo:   sha512
parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)
parm:           amsdu_size_8K:enable 8K amsdu size (default 0) (int)
parm:           fw_restart:restart firmware in case of error (default true) (bool)
parm:           antenna_coupling:specify antenna coupling in dB (defualt: 0 dB) (int)
parm:           wd_disable:Disable stuck queue watchdog timer 0=system default, 1=disable, 2=enable (default: 0) (int)
parm:           nvm_file:NVM file name (charp)
parm:           bt_coex_active:enable wifi/bt co-exist (default: enable) (bool)
parm:           led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int)
parm:           power_save:enable WiFi power management (default: disable) (bool)
parm:           power_level:default power save level (range from 1 - 5, default: 1) (int)

[cfg80211]
filename:       /lib/modules/3.13.0-36-generic/kernel/net/wireless/cfg80211.ko
description:    wireless configuration support
license:        GPL
author:         Johannes Berg
srcversion:     C2478077E22138832B71659
depends:        
intree:         Y
vermagic:       3.13.0-36-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        38:F3:B6:C6:3A:85:AF:FD:FB:BE:0E:53:33:9D:F8:E0:C6:B6:C9:D5
sig_hashalgo:   sha512
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

##### module parameters #################

[mac80211]
beacon_loss_count: 7
ieee80211_default_rc_algo: minstrel_ht
max_nullfunc_tries: 2
max_probe_tries: 5
probe_wait_ms: 500

[iwlwifi]
11n_disable: 0
amsdu_size_8K: 0
antenna_coupling: 0
bt_coex_active: Y
fw_restart: Y
led_mode: 0
nvm_file: (null)
power_level: 0
power_save: N
swcrypto: 0
wd_disable: 1

[cfg80211]
cfg80211_disable_40mhz_24ghz: N
ieee80211_regdom: 00

##### /etc/modules ######################

lp
rtc

##### modprobe options ##################

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist i2c_i801
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac

[/etc/modprobe.d/blacklist-rare-network.conf]
alias net-pf-3 off
alias net-pf-6 off
alias net-pf-9 off
alias net-pf-11 off
alias net-pf-12 off
alias net-pf-19 off
alias net-pf-21 off
alias net-pf-36 off

[/etc/modprobe.d/iwlwifi.conf]
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

[/etc/modprobe.d/mlx4.conf]
softdep mlx4_core post: mlx4_en

##### rc.local ##########################

exit 0

##### pm-utils ##########################

[/etc/pm/power.d/wireless] (755 root)
/sbin/iwconfig wlan0 power off

##### udev rules ########################

[/etc/udev/rules.d/70-persistent-net.rules]
# PCI device 0x10ec:0x8168 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
# PCI device 0x8086:0x0887 (iwlwifi)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

##### dmesg #############################

[ 6007.775779] iwlwifi 0000:02:00.0: RF_KILL bit toggled to enable radio.
[ 6011.128079] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[ 6011.136901] iwlwifi 0000:02:00.0: Radio type=0x2-0x0-0x0
[ 6011.203681] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 6012.329356] wlan0: authenticate with 
[ 6012.334173] wlan0: send auth to  (try 1/3)
[ 6012.336306] wlan0: authenticated
[ 6012.336744] wlan0: associate with  (try 1/3)
[ 6012.341336] wlan0: RX AssocResp from  (capab=0x431 status=0 aid=3)
[ 6012.364839] wlan0: associated
[ 6012.364893] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 6012.384107] wlan0: deauthenticating from  by local choice (reason=2)
[ 6012.408121] wlan0: authenticate with 
[ 6012.412092] wlan0: send auth to  (try 1/3)
[ 6012.414214] wlan0: authenticated
[ 6012.416765] wlan0: associate with  (try 1/3)
[ 6012.421359] wlan0: RX AssocResp from  (capab=0x431 status=0 aid=3)
[ 6012.443977] wlan0: associated

########## wireless info END ############
  • This does sound like a network/router issue. – Kaz Wolfe Sep 27 '14 at 19:39
  • Have you looked at the log files in /var/log? Try grep NetworkManager /var/log/syslog*, and spend some time trying to understand the messages before reposting. Also, read the "Related" problems along the right side of this screen. – waltinator Sep 27 '14 at 21:39
  • 1
    Please run the script that is in the accepted answer in the link below so we may see the information needed to help diagnose the issue. <askubuntu.com/questions/425155/…; – Wild Man Sep 28 '14 at 4:57
  • @Whaaaaaat I've recently replaced both the router and the cable box. Anything beyond that belongs to Time Warner Cable. Even if it is TWC's fault, there must be something I can do to make my laptop more resilient to these interruptions, make it better at reconnecting. If I disconnect and reconnect, the wifi works again, so why can't my laptop do that itself? – bigcat42 Sep 29 '14 at 14:19
  • 1
    I have this same symptom on a dual boot with windows 8 and finally upgraded to windows 10 and that system doesn't have any issues with the router. Neither does any other machine on the same wifi. Just when I'm in ubuntu. – Jason Kleban Dec 22 '15 at 14:12
up vote 22 down vote accepted

Run the following commands, one line at a time in the terminal (CTRL+ALT+T):

echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwldvm
sudo modprobe -rfv iwlwifi
sudo modprobe -v iwlwifi

What does this do? The 11n_disable option disables 802.11n features. Adding it to /etc/modprobe.d/iwlwifi.conf makes the change persist after reboots (because it will be part of the module config). The modprobe -rfv commands are removing the kernel modules iwldvm and iwlwifi, and finally the last line modprobe -v is adding iwlwifi back in.

To know what those kernel modules are/do, you can run modinfo <module name> | grep description, which will tell you the following:

iwlwifi is an Intel(R) Wireless WiFi driver for Linux (generic Intel drivers)

iwldvm is Intel(R) Wireless WiFi Link AGN driver for Linux (more specific drivers)


Other suggestions

Now, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, You may have better luck with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. After making these changes, you may need to reboot the router.

  • 10
    I would appreciate some references before I go blindly modifying system configurations. – ThorSummoner Aug 2 '15 at 5:42
  • 6
    @ThorSummoner you have a good point there. I've just edited the answer to explain what each line does – Enrico Nov 18 '15 at 11:57
  • 1
    my wifi only randomly drops out when connect using wpa2 enterprise, if I'm using wpa2 personal it's just fine, any suggestion? – Ahmad Muzakki Sep 11 '16 at 1:56
  • I got an error saying that iwlwifi.conf is in use. Although simply skipping the last three steps seemed to fix my problem anyway. – Abe Petrillo Dec 19 '17 at 21:15
  • How to undo the changes in the post? – mahmood Mar 1 at 17:25

Change the wireless setting of IPv6. I tried it with my laptop, which has been continually dropping the connection, and so far, all day long, I have not had a single dropout! It seems to be working. In Ubuntu, in the top right, click on the wireless network icon that shows connectivity. In the dropdown menu, at the bottom, select "edit connections" and then highlight your wireless connection name. Choose edit, then select the IPv6 tab (to the right of the IPv4 tab) and change the setting from "automatic" to "ignore". Save and exit. Reboot your PC. That took care of my problem, and hopefully will yours, too.

  • 1
    This also worked for me with Ubuntu 16.04 – David Bosschaert Jun 9 '17 at 19:43

Edit the wireless settings, set the IPv6 method to "ignore".

This may be a very simple solution to this problem. My 12.04 wireless connection dropped out every few minutes when connected over Comcast and sometimes also in hotels. This happened consistently on different Comcast wireless setups. On many other wireless setups, it was solid (in my workplace, at Starbucks, for example).

After struggling with many complicated fixes, I finally stumbled across the above solution: No more dropouts.


Edit by cipricus to add images (in KDE Plasma 5.8 interface):

enter image description here

enter image description here

enter image description here

  • 1
    In 12.04, click on the network icon in the top right tool bar. Select "edit connections" and go to wireless. Select the connection in question, p ush the "edit" button to the right. Then go to IPv6 settings and select "ignore" under "method". Hit save. Problem over. – Dana Yoerger Aug 3 '15 at 13:10
  • 2
    Much better! :-) Can you now edit your answer and put it there instead of the comments here and then delete your comment? (My original comment already deleted) ;-) – Fabby Aug 3 '15 at 15:13
  • I don't have the "ignore option" on linux mint. Is it possible to have this option somewhere else? – abimelex Dec 13 '16 at 12:00
  • @abimelex you might try editing the config file in /etc/NetworkManager/system-connections/ – pomsky Jun 13 '17 at 16:55
  • Ubuntu 17.10 does not have a GUI "ignore" option. It does have a "Disable" option; inspecting the /etc/NetworkManager/system-connections/* I can confirm that this translates into the same method=ignore. Unfortunately this did not fix things for me. – josephwb Jan 31 at 17:55

Hi If you are dual booting or using a PC, firstly ensure your Ethernet does not turn off connection to save power, may not be The Solution but it is one step closer. there are 2 that need turning off. Do this Control Panel/device manager/Network adapters right click Properties / power management/ Un-tick "Allow computer to turn Off this device to save power" Since Windows95 it is always ticked by Default and often when one recovers from a crash it is ticked again and needs to be turned off. Hope it helps

  • This is a Windows-based answer to a Linux-based question. – flith Jul 4 at 19:09

I found a good article on this at: http://itsfoss.com/speed-up-slow-wifi-connection-ubuntu/

I tried steps 1 through 4, but in the end step 5 (installing WICD) is what worked for me.

I'll quote that section here since it's a solution that I didn't see in the prior answers here:

SOLUTION 5: DITCH DEFAULT NETWORK MANAGER AND EMBRACE WICD "Slow or inconsistent wireless connection, in some cases, are also due to Ubuntu’s very own default network manager. I am not sure what causes this but I have seen people in Ubuntu Forums talking about this problem in especially in Ubuntu 12.04. You can install Wicd, an alternate and a better network manager from Ubuntu Software Centre or from terminal. For details on how to use Wicd, you can read my other article which I used to find SSID of wireless networks in Ubuntu."

To clarify, after installing WICD, my WIFI is I think getting disconnected a little less frequently (it was about every 20 minutes), but the big difference is that I previously had to go disable WIFI and then re-enable WIFI to reestablish my internet connection. Now with WICD it just automatically (and pretty much transparently) reconnects within a few seconds.

My quick and dirty hack

My wifi adapter (Realtek RTL8188CUS) is just angry with Ubuntu and no real solution worked, so I ping my router every 5s:

ping 192.168.0.1 -i 5

...and the connection stays on.

  • This intrigued me. I thought this might give some hints on underlying causes, so I tried it before trying other things. However, I'd say inconclusive/unhelpful: when I left for an hour and returned, the ping had started giving ping: sendmsg: Network is unreachable – sage May 21 '16 at 16:42
  • This will work if your problem is hardware going to some sleep-mode or low-power state (forcing it to remain active). It won't help if there is some issue with the hardware itself or the driver; it's like pinging the router on a wired connecting and expecting it to help if somebody disconnects the network cable. I would suggest this is some power-saving setting specific to the RTL8188 driver. – flith Jul 4 at 19:08

protected by Pilot6 Jul 16 '16 at 17:08

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.