I tried out Ubuntu 14.04, but decided I don't like Unity. It seems resource hoggy and I prefer quick responsiveness over appearance. I liked Lubuntu on my netbook so I wanted to install that over Ubuntu. According to some stuff I Googled, it should have been as simple as installing lubuntu-core with the Synaptic Package Manager.

I tried this and purged the default Ubuntu/Unity stuff (I think), but now the Lubuntu display is all screwed up. Icons on the desktop don't snap into symmetrical lines but instead into seemingly random positions (but snap to those positions). The menu bar is on my right monitor instead of the left (matter of taste, I guess). But also nothing appears on it except the clock even though in the preferences there should be a menu, a workspace switcher, etc. Default Lubuntu stuff.

I'm comfortable with using the command line, so if I needed to strip everything down I'm willing to do that.

Any solutions other than installing a fresh Lubuntu image over everything?


You might try installing lubuntu-desktop in addition to lubuntu-core. That should pull in the default desktop settings, artwork and such.

  • Sudo apt-get install lubuntu-desktop should have been all you needed to do to ubuntu w unity to add lubuntu to the login menu. Then you just select either lububtu or unity each time you log in. – bmullan Sep 28 '14 at 7:20

If you are comfortable using the terminal (as you say), you should install tasksel using

sudo apt-get install tasksel

Then use tasksel to deselect the Ubuntu Desktop set and select Lubuntu Desktop.

sudo tasksel

Finally, before you log into the desktop, remove your ~/.config folder.

This should set up a proper Lubuntu desktop system, just as if you had used a CD.


If you are not too picky about lubuntu, you can try the LXDE desktop:
I have done what you are trying, I ended up with a broken login screen. I fixed it and then I got a broken audio. I left it at that stage and went ahead to install the stock LXDE desktop on Ubuntu.
And to reduce the bulk, you have to shed some of the heavy applications you don't use and some of the processes that need not run at startup.


I figured it out, the issue was xrandr and I fixed it with arandr. The task bar was extending along the whole bottom edge of the desktop, but my left monitor was too "high" so it didn't show the left side of the bar. Moving the monitor down in arandr fixed it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.