12

result of ps -e | grep mysqld

enter image description here

running htop and clicking on memory usage..

enter image description here

It is taking 33% of 4gb memory.

I just want to end the mysqld process.. running sudo pkill mysqld ends the process but again the process starts.. I want to completely end it and get the memory back.

  • 1
    Press f5 in htop to see what process is starting mysqld – Moose Sep 27 '14 at 16:28
12

The mysql Upstart configuration has the respawn option:

$ grep respawn /etc/init/mysql.conf
respawn
respawn limit 2 5
        elif echo $statusnow | grep -q 'respawn/' ; then

The respawn option tells Upstart to restart the process if it exits or is killed. The limit is 2, so you can try killing of the processes twice, which will tell Upstart not to start them again, or use:

sudo service mysql stop
  • mysql stop stops it, and yet it still starts again and again... I commented out respawn rows in the configuration, but that didn't help. – Jānis Elmeris Jul 10 '16 at 12:36
  • 1
    @Janis if service mysql stops mysql, and then it restarts, then something else is starting it. Look for cronjobs or monitoring scripts or something. – muru Jul 10 '16 at 12:45
  • Thanks! I did the stopping by /etc/init.d/mysql stop, but it turned out that I had to run service mysql stop instead. I thought that they are the same (one calling the other or both calling the same command). – Jānis Elmeris Jul 13 '16 at 15:20
13
/etc/init.d/mysql stop
service mysql stop
killall -KILL mysql mysqld_safe mysqld

When you see the following information, you success

mysql: no process found
mysqld_safe: no process found
mysqld: no process found

I use this to solve the installation problem of MySQL 5.6 in Ubuntu 15.10 using this link.

During this installation, I encounter the problem saying:

mysqld_safe A mysqld process already exists

Just completely stop the mysqld, mysqld_safe, mysql solves the problem

4

Run sudo /etc/init.d/mysql stop

1

Somehow all the answers couldn't help me until I first restarted the server then stopped it, so here are the steps:

sudo /etc/init.d/mysql restart

sudo /etc/init.d/mysql stop

This worked in Ubuntu WSL.

  • 1
    duplicate of this answer askubuntu.com/a/771591/790920 – abu_bua Aug 9 '18 at 11:35
  • @abu_bua I tried the steps he put there and it still didn't work for me until I restarted and then stropped, that's why I have it specific steps in that order if anyone has same problems. – Eddy Ekofo Aug 9 '18 at 12:24
1

If you cannot find mysql within /etc/init or /etc/init.d, check that id did not come together with another package. As for me, i found out that my mysqld runs to support nextcloud, i did

$> find '/etc' | grep 'mysql'

/etc/systemd/system/multi-user.target.wants/snap.nextcloud.mysql.service
/etc/systemd/system/snap.nextcloud.mysql.service
/etc/apparmor.d/abstractions/mys
0

If you are stuck in a running commang inside the console, you can try one of the following.

  • Ctrl + c
  • Ctrl + q
  • F10
  • type "exit" + Enter
  • Esc
0

System Preferences -> MySql -> Stop MySQL Server

This is the only one that worked for me, stopping / killing it from the command line would always let it restart.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.