I am running 14.04 as a guest on a Win8.1 host (over VirtualBox 4.3.17), 3D acceleration is enabled.

Since upgrading from 12.10 I have noticed that text/content will sometimes corrupt when I scroll a webpage in either Firefox or Chrome and in both terminal-only vim and gvim.

In vim it will happen that a text "update" (text inserted by tab completion or scrolled) will just not show, instead the background color is rendered.

In the browser case, scrolling leads to parts of the viewport showing a previous "frame" of the text, while others have updated to the current real location of the text in the viewport.

In both cases, a forced redraw of the app, by for example moving the window or taking a screenshot, will fix the view. This tells me the problem is happening at a deeper level, either the window manager or perhaps even the virtualized graphics card.

When I upgraded to 14.04 I also upgraded from VirtualBox 4.2.x (which simply was unable to run the newer version of Ubuntu) so I actually can't pinpoint this as a Ubuntu problem, a VirtualBox problem or an interaction between the two.

The question is, is this a known problem and what are the possible lines of attack to pinpoint the source and a possible solution?


I have tried turning off 3D Acceleration and it seems that the problem then disappears, at least no scrolling artifacts appear even though scrolling gets much less responsive naturally.

I have reproduced the effect on a brand new install of Ubuntu 14.04.1, the problem is very noticeable in Chrome and more occasionally in vim/gvim.

  • You ever find a solution? – daveomcd Jun 26 '15 at 14:49
  • @daveomcd Not so far no :( – Ezequiel Muns Jun 27 '15 at 10:49
  • While not an ideal solution I've swapped over to VMware trial. I'll probably buy a license since its a much better experience – daveomcd Jun 27 '15 at 14:01
  • Not fixed yet!!! Ubuntu 16.04, Virtual Box Version 5.1.22 r115126 (Qt5.6.2) !!! – Bill Kotsias Jun 13 '17 at 12:14

I think it's a bug, so it's reported to VirtualBox folks at https://www.virtualbox.org/ticket/13620. I cannot find a solution other than to disable 3D acceleration. Still happens as of Ubuntu 14.10 x64 guest and VirtualBox 4.3.18 r96516.


New Kernel

New Xserver version

new stuff.

Upgrade Vbox tools via commandline:

sudo apt-get install --reinstall virtualbox-guest*

Optionally purge first

sudo apt-get purge virtualbox-*

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.