10

I'm currently trying to use byobu from PuTTY via ssh. I have currently putty-256color as Terminal-type string because otherwise not even Byobu bindings worked and I couldn't create new windows or move between them. I have Tmux backend and byobu-crtl-a set to emacs however I can't seem to make F keys work in either Midnight Commander or htop. I tried as suggested the Ctrl+a and Shift+F12 to enable them but I receive no message and still can't make them work.

What am I doing wrong? Thanks for the help.

15

After reading it here I changed the session so that "Terminal → Keyboard" has the option "Xterm R6" selected.

| improve this answer | |
  • 1
    Using Xterm R6 restores F1 and F2 key functionality but Shift-F1 and Shift-F2 seem to be interpreted as sending character "~". Client is putty on windows 10, server is ubuntu 16.04 – init_js Jul 28 '19 at 20:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.