I get “signal out of range” displayed on screen after boot up from fresh Ubuntu installation, if flashes grup in corner for half a sec then it goes to “No Input Signal”, anyone got a clue how to get the grub to load in diffrent resolution with out have access to the file system?

if not i guess my only option is to boot from the cd and edit som files to get grub to load in diffrent resolution?

as it is now i cant get access to grub menu, and i cant get access to login screen, all will give me “No Input Signal”, anyone worked around this?


Boot from the live cd and open a terminal. Assuming your root is on /dev/sda1, then do this:

sudo -s
mount -t ext4 /dev/sda1 /mnt
gedit /mnt/etc/default/grub
for f in sys proc dev ; do mount --bind /$f /mnt/$f ; done
chroot /mnt

When the editor comes up, uncomment ( remove the '#' ) this line and save and exit:


After the update-grub, reboot and you should be good.

  • nice, worked, thx for the info mate :) – Darkmage Jul 14 '11 at 10:03
  • 1
    @Darkmage it seems that your video bios is buggy and picks a video mode that your monitor can't handle. – psusi Jul 14 '11 at 14:19

I also had this problem. But my plan was to use my machine as a headless server to SSH into, so I didn't bother fixing this error until now. (And for the record, the full description of the error I encounted on my Dell 2009W display with Ubuntu 12.10 Server Edition was "Out of range signal. Cannot display this video mode, change computer display input to 1680x1050.")

So if you get this error and you want to fix it after installation (and have SSH access), do the following:

  1. Change the /etc/default/grub config file; uncomment the line #GRUB_GFXMODE=640x480

    (Note: At first this file was missing. After running sudo update-grub a couple times when I was trying stuff out, Grub2 eventually created that file... Bizarre!)

  2. Save the file.

  3. Update Grub: sudo update-grub

  4. Restart the server.

And then everything magically worked! Hopefully this is helpful for someone else. Good luck.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.