1

I am using Gnome-Ubuntu desktop 14.04. I have a Intel i7 processor, 6g ram, and over 2.5t of disk space. I am loading the Gnome-Shell by DVD. I am current using Windows XP because I cannot launch the Gnome gui.

I have three users on my computer, all of which are me. Two are robert and geek. Robert is the identity that does serious work. Geek is the identity that plays.

Beginning on or about 9/22/14, I started having trouble launching the gui for geek. I logged in, used the correct password and the gui started to load. After a considerable time, I would end up at the login page. This has continued to happen since the 22nd.

I could continue to successfully login with the robert identity, until just now. Once in I could login geek on terminal. Geek could then used the sudo process to act as root, etc. I do not appear to have a login problem.

I have also opened a tty at the login menu. I then login successfully as geek. I can use the tty as geek, including th sudo procedure. What I cannot do is open the gui for geek.

I have made various attempts to solve this problem using answers to related questions on this page and others. In my last attempt, I logged in as robert, opened the terminal, and attempted to use the command startx, as indicated in the man pages to start the gui. Now I cannot bring the gui up for robert either.

In the auth. log, I found that geek logged in, session started, then suddenly the session was closed by the system. About the same time there were references to unsuccessfully attempt to connect an apparent X system file in /tmp to X system files in /etc. That may be the problem, but there is no further explanation in the log. I would attach the relevant portions the Auth. Log. but I can no longer access them. I cannot see the log from Windows, and I cannot secure them as robert or geek.

  1. How do I solve this problem? How do I get the gui started once logged on? How can I successfully start the gui from the terminal or tty?

  2. How can I debug the effected process? How can I find where the processing is going wrong?

  3. Is there a program I can run to search for and fix the errors?

  4. What documentation should I consult, and where from, so I can figure out how to fix the problem?

Thanks

  • I just realised that I would not receive email notice of response. I will try out the process as soon as I can. Unfortunately, I cannot get the computer to boot into either linux or XP right now. I am using my wife's computer. THANKS I will follow up. – user278701 Oct 3 '14 at 17:01
0

if you want to start a gui from the command line try the following:

$ xinit

it will open an xterm. Then in xterm type gnome-session. If it comes up looking like a scrambled egg, then it most certainly is a driver problem. If it doesnt work go back to your tty and press CTRL + C. Then restart xinit. Now type sudo apt get install lightdm. It will install and ask you which DM should be default. Select lightdm.

PleAse tell me if it works then.

P.S. also try clicking on the ubuntu logo and see if gnome is selected as default.

  • So for the delay in response/ I thought I'd receive email notice of a response. Have been waiting. Glad I looked. – user278701 Oct 3 '14 at 16:58
  • See my comments in response to my question. I followed your suggestions. This is what happened: – user278701 Oct 3 '14 at 22:12
  • I followed your suggestion. xinit was not successful, but based on the last two days, I should see if the X should be capitalize. I downloaded new versions of lightdm, but two problems occurred. Using the install command resulted in a message to the effect that everything was up to date and reinstallation is not needed. I downloaded a copy of the lightdm file but find I can't find a way to access the drive, which is not where the Linux partition is. I did copy the lightdm.conf file to lightdm.old. I am wondering if I should delete portions of the lighdm directory, and then try to reinstall – user278701 Oct 5 '14 at 16:58
  • ps I understand conflicting tasks and the need for prioritization. I have been working on this constantly, and improved my knowledge and skill. I do miss XP windows explorer and the the ease of accessing all my drives, etc. But adaption is a necessary skill for survival. At 70, survival takes on a whole new priority. :) – user278701 Oct 5 '14 at 17:02
  • Try installing KDE and KDM through sudo apt-get install <package name> – user332008 Oct 6 '14 at 20:32
0

I am SO SORRY I haven't been answering the rest of your questions, I just have been super busy lately. So have you tried starting the failsafe mode? Gnome usually has this extra mode at login that you can enable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.