0

I have been fighting with this problem for a long time...

For some unknown reason for me, some addresses seem to don't resolve, when I try

dig www.google.com.br @localhost

it returns me:

; <<>> DiG 9.8.1-P1 <<>> www.google.com.br @localhost ;; global options: +cmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 46072 ;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 4, ADDITIONAL: 4

;; QUESTION SECTION: ;www.google.com.br. IN A

;; ANSWER SECTION: www.google.com.br. 25 IN A
173.194.118.79 www.google.com.br. 25 IN A 173.194.118.87 www.google.com.br. 25 IN A 173.194.118.88 www.google.com.br. 25 IN A 173.194.118.95

;; AUTHORITY SECTION: google.com.br. 25 IN NS
ns3.google.com. google.com.br. 25 IN NS
ns1.google.com. google.com.br. 25 IN NS
ns4.google.com. google.com.br. 25 IN NS
ns2.google.com.

;; ADDITIONAL SECTION: ns1.google.com. 27 IN A
216.239.32.10 ns2.google.com. 26 IN A 216.239.34.10 ns3.google.com. 27 IN A 216.239.36.10 ns4.google.com. 26 IN A 216.239.38.10

;; Query time: 0 msec ;; SERVER: 127.0.0.1#53(127.0.0.1) ;; WHEN: Fri Sep 26 17:46:54 2014 ;; MSG SIZE rcvd: 245

Everything working fine.

But when I try some specific hosts, like Hotmail or YouTube, it fails:

dig www.hotmail.com @localhost

; <<>> DiG 9.8.1-P1 <<>> www.hotmail.com @localhost ;; global options: +cmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 56204 ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION: ;www.hotmail.com. IN A

;; Query time: 44 msec ;; SERVER: 127.0.0.1#53(127.0.0.1) ;; WHEN: Fri Sep 26 17:48:41 2014 ;; MSG SIZE rcvd: 33

But, if I try dig +tcp www.hotmail.com @localhost it works:

; <<>> DiG 9.8.1-P1 <<>> +tcp www.hotmail.com @localhost ;; global options: +cmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 41319 ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 5, ADDITIONAL: 5

;; QUESTION SECTION: ;www.hotmail.com. IN A

;; ANSWER SECTION: www.hotmail.com. 23 IN CNAME
dispatch.kahuna.glbdns2.microsoft.com. dispatch.kahuna.glbdns2.microsoft.com. 23 IN A 65.55.85.12 dispatch.kahuna.glbdns2.microsoft.com. 23 IN A 157.55.104.76

;; AUTHORITY SECTION: hotmail.com. 26 IN NS
ns5.msft.net. hotmail.com. 26 IN NS
ns2.msft.net. hotmail.com. 26 IN NS
ns3.msft.net. hotmail.com. 26 IN NS
ns1.msft.net. hotmail.com. 26 IN NS
ns4.msft.net.

;; ADDITIONAL SECTION: ns5.msft.net. 25 IN A
65.55.226.140 ns2.msft.net. 25 IN A 208.84.2.53 ns3.msft.net. 25 IN A 213.199.180.53 ns1.msft.net. 25 IN A 65.55.37.62 ns4.msft.net. 25 IN A 208.76.45.53

;; Query time: 7 msec ;; SERVER: 127.0.0.1#53(127.0.0.1) ;; WHEN: Fri Sep 26 17:49:58 2014 ;; MSG SIZE rcvd: 291

Can anyone help me?

0

If you are on a local PC i recommend setting up forwards to your ISP's or even google's NSs, for example:

        forwarders {
            8.8.8.8;
            8.8.4.4;
    };

and don't forget to add

    forward only;

to act as forwarder

more more information refer to Ubuntu's official documentation about configuring caching server

  • Nope. The forwarders were already set. I added the option forward only; to see if it works. But still the same behavior – Alexandre Sottani de Carvalho Sep 29 '14 at 18:17
  • do you have any rules in your iptables that could effect DNS ports? 'iptables -L' in your terminal – Bashar Al-Abdulhadi Sep 30 '14 at 19:55
  • No. There are no rules in the firewall – Alexandre Sottani de Carvalho Oct 1 '14 at 11:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.