29

I am running system load indicator and I really like the functionality it provides. My version (0.4) shows a few graphs and to the right of that is some text that shows some statistics that are generally redundant with the graphs. That text takes up a lot of menu bar space I'd like to use for other stuff, but I can't figure out how to get it to go away. Does anybody know how to hide this.

In the attached screenshot, the text I am trying to get rid of is the bit that says "Dist 0.0kB/s/0.0kB/s

"SystemLoadIndicatorScreenshot

2
  • What OS and app versions are you running? (sorry, can't comment and have the same problem) Nov 3, 2014 at 10:36
  • OS: 12.04 System load indicator 0.4
    – ohnoplus
    Nov 3, 2014 at 21:47

4 Answers 4

39

After plenty of digging around on the web, this is what I found. You need to go to the indicator preferences:

Preferences->Indicator Items->Add

Then you create a blank entry by pressing the space bar and save it.

This is a temporary work around though, but it will solve your problem. Worked for me on Ubuntu 14.04 and using v0.4 of the indicator. See comment #6 in the link below:

https://bugs.launchpad.net/indicator-multiload/+bug/1348961

4
  • 1
    Still helps on ubuntu 16.04 ... that is still running v0.4 of indicator-multiload. Doesn't look like much changed there the last two years.
    – GhostCat
    Dec 12, 2016 at 6:39
  • 2
    Also working on 16.10.
    – ferdy
    Jan 21, 2017 at 9:28
  • 2
    Mine appeared to be bugged - the blank entry was there but it still displayed the label. Removing it and adding a new blank entry at the top fixed it. (Ubuntu 16.10) Jan 31, 2017 at 20:16
  • Working on Ubuntu 20.04 (with the default Gnome desktop)
    – Yixing Lao
    Jun 5, 2020 at 9:09
21

Just remove all items from indicator.

Go to: Preferences->Indicator-items and remove all entries.

Works on 15.05.

4
  • 1
    yours fixed my issue
    – zeachco
    Sep 10, 2015 at 15:07
  • 5
    Looks like this is still the way to fix it in 16.04.
    – Stéphane
    Jun 5, 2016 at 8:14
  • Ubuntu 16.04 here - where are these "Preferences" found? I've tried System Settings and right-clicking the indicator bar and clicking the various indicators themselves.
    – rog
    Jan 17, 2018 at 16:42
  • Confirmed this answer solve the problem in Ubuntu 16.04.
    – PhatHV
    Oct 15, 2018 at 3:39
8

First of all, this is not a bug that the text is displayed next to the graph, but a feature. All you have to do is to point the mouse to the graph and scroll, so that you can toggle what text is to be displayed (about CPU, Memory etc.) there, or no text at all. Hope that helped. :)

For detailed info, see here

1

I found out that I have some blank Indicator items there, so my solution was to delete those empty items. Now it works fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .